Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367579 - Summary screen displays broken URL for RHV if the hostname was modified during deployment.
Summary: Summary screen displays broken URL for RHV if the hostname was modified durin...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 1.0
Assignee: cchase
QA Contact: Antonin Pagac
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-16 20:48 UTC by John Matthews
Modified: 2016-09-13 16:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:36:31 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Description John Matthews 2016-08-16 20:48:56 UTC
Description of problem:


Do a deployment of engine + hypervisor.
Change the engine name to something like: "eng1".
Complete the deployment.
View the summary screen.

See how the engine URL displays:
 https://eng1/ovirt-engine

Should be
  https://eng1.example.com/ovirt-engine

Comment 2 cchase 2016-08-17 19:23:26 UTC
https://github.com/fusor/fusor/pull/1166

After a deployment, the rhev engine URL was still using the name from the engine as a discovered host, not a managed host, resulting in "https://eng1/ovirt-engine" instead of "https://eng1.example.com/ovirt-engine". This fix should use the updated model and the computed property now triggers on the name change.

Regarding reproducing: this would only happen immediately following the deployment without reloading.

Comment 3 Thom Carlin 2016-08-31 19:01:52 UTC
FailedQA in QCI-1.0-RHEL-7-20160830.t.0 

As described in comment 0, the engine URL at end of deployment in Installation Summary is:
https://eng1/ovirt-engine/

not the FQDN (eng1.<<domain_name>>)

Workaround:

Quickstart Cloud Installer > Deployments
select *same* deployment
Will display in Installation as
https://eng1.<<domain_name>>/ovirt-engine/

So as I understand it, the bz is:
* The first time: Managed host doesn't display properly and hyperlink is thus wrong
* Succeeding times: Managed host displays properly and hyperlink is correct

Comment 4 cchase 2016-09-09 14:00:49 UTC
https://github.com/fusor/fusor/pull/1203

I super double checked the URL this time.

Comment 5 Antonin Pagac 2016-09-09 14:10:50 UTC
Verified in QCI-1.0-RHEL-7-20160908.1.

Displayed link is now correct after the first deployment.

Comment 7 errata-xmlrpc 2016-09-13 16:36:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.