Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367567 - Fails to build new package
Summary: Fails to build new package
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Copr
Classification: Community
Component: backend
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact:
URL:
Whiteboard:
: 1367859 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-16 19:28 UTC by Irina Boverman
Modified: 2016-08-18 20:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-18 20:38:51 UTC


Attachments (Terms of Use)

Description Irina Boverman 2016-08-16 19:28:54 UTC
Description of problem:

Fails to build

Version-Release number of selected component (if applicable):


How reproducible:

100% 

Steps to Reproduce:

copr-cli build @qpid/qpid qpid-proton-0.13.1-1.el6.src.rpm



Actual results:

   Failed build

Expected results:

   Successful build

Additional info:

see this:
https://copr-be.cloud.fedoraproject.org/results/%40qpid/qpid/epel-6-x86_64/00441977-qpid-proton/root.log

Comment 1 Irina Boverman 2016-08-16 19:33:19 UTC
It uses mock Mock Version: 1.2.19, which is still in "testing"

Information for build mock-1.2.19-2.el6
ID	790656
Package Name	mock
Version	1.2.19
Release	2.el6
Epoch	
Summary	Builds packages inside chroots
Description	Mock takes an SRPM and builds it in a chroot.
Built by	msuchy
State 	complete
Started	Wed, 10 Aug 2016 13:09:12 UTC
Completed	Wed, 10 Aug 2016 13:10:55 UTC
Task	build (el6-candidate, /rpms/mock:a77a9d78d1fff1f681d62914f131d0490e43366c)
Tags 	
dist-6E-epel-testing
RPMs 	



Actual error is this:

DEBUG util.py:421:  Retrieving key from file:///usr/share/distribution-gpg-keys/centos/RPM-GPG-KEY-CentOS-6
DEBUG util.py:421:  Importing GPG key 0xC105B9DE:
DEBUG util.py:421:   Userid     : "CentOS-6 Key (CentOS 6 Official Signing Key) <centos-6-key@centos.org>"
DEBUG util.py:421:   Fingerprint: c1da c52d 1664 e8a4 386d ba43 0946 fca2 c105 b9de
DEBUG util.py:421:   From       : /usr/share/distribution-gpg-keys/centos/RPM-GPG-KEY-CentOS-6
DEBUG util.py:421:  warning: /var/lib/mock/epel-6-x86_64-mockbuilder-3528/root/var/cache/yum/epel/packages/epel-rpm-macros-6-11.noarch.rpm: Header V3 RSA/SHA256 Signature, key ID 0608b895: NOKEY
DEBUG util.py:421:  Retrieving key from file:///usr/share/distribution-gpg-keys/centos/RPM-GPG-KEY-CentOS-6
DEBUG util.py:421:  The GPG keys listed for the "epel" repository are already installed but they are not correct for this package.
DEBUG util.py:421:  Check that the correct key URLs are configured for this repository.
DEBUG util.py:421:   Failing package is: epel-rpm-macros-6-11.noarch
DEBUG util.py:421:   GPG Keys are configured as: file:///usr/share/distribution-gpg-keys/centos/RPM-GPG-KEY-CentOS-6
DEBUG util.py:557:  Child return code was: 1

Comment 2 clime 2016-08-16 21:13:50 UTC
Thanks for that catch!

It is in testing for epel6 and epel7 but not for F24 and our builders use F24 so that's how it got there. This might be related to mock.

Comment 3 Miroslav Suchý 2016-08-17 10:20:09 UTC
This is due bug in mock, which I just fixed. Should be resolved soon in Copr.

Comment 4 clime 2016-08-18 20:35:05 UTC
*** Bug 1367859 has been marked as a duplicate of this bug. ***

Comment 5 clime 2016-08-18 20:38:51 UTC
Should be fixed in COPR now.


Note You need to log in before you can comment on or make changes to this bug.