Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367531 - update python-rtslib to allow enabling of cxgbit offload
Summary: update python-rtslib to allow enabling of cxgbit offload
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-rtslib
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Andy Grover
QA Contact: Martin Hoyer
URL:
Whiteboard:
Depends On:
Blocks: 1388569
TreeView+ depends on / blocked
 
Reported: 2016-08-16 16:31 UTC by Andy Grover
Modified: 2017-08-01 20:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 20:54:35 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2031 normal SHIPPED_LIVE targetcli, python-configshell, python-rtslib bug fix and enhancement update 2017-08-01 18:34:25 UTC

Description Andy Grover 2016-08-16 16:31:18 UTC
Extend rtslib to allow getting and setting thw cxgbit property, to save it to json, and restore the value on boot.

Comment 2 Gary Case 2016-10-03 17:19:06 UTC
Has this already been delivered? This bug depends on https://bugzilla.redhat.com/show_bug.cgi?id=1211351 which is marked as verified in 7.3.

Comment 3 Andy Grover 2016-10-03 17:57:40 UTC
No. I've just pushed support upstream in rtslib-fb version 2.1.fb61. This needs to be brought into RHEL for the 'cxgbit' setting to be saved, and restored when the system is restarted.

Comment 4 Gary Case 2017-02-23 15:33:43 UTC
This is still listed as a 7.3 bug. Will it make 7.4?

Comment 5 Andy Grover 2017-03-02 00:37:18 UTC
That's the plan, yes.

Comment 7 Martin Hoyer 2017-05-29 13:58:15 UTC
Tested with targetcli-2.1.fb46-1.el7
Works as expected. No regression found.

Comment 8 errata-xmlrpc 2017-08-01 20:54:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2031


Note You need to log in before you can comment on or make changes to this bug.