Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367524 - It is not possible to add the export=true option while creating a module through CLI utility
Summary: It is not possible to add the export=true option while creating a module thro...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: CLI, Scripts and Commands
Version: 6.4.8
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: jboss-set
QA Contact: Petr Kremensky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-16 15:59 UTC by Robson Watt
Modified: 2016-09-16 20:55 UTC (History)
5 users (show)

Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-16 20:55:46 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker PRODMGT-1593 Major Resolved Set the export= true option while creating a module through CLI utility 2018-01-31 13:49:12 UTC

Description Robson Watt 2016-08-16 15:59:47 UTC
Description of problem:
We have a lot of customers that are using CLI utility to manage their Jboss. They need to create modules with export=true option for dependencies but CLI does not have that option.

module add --name=module_name [--slot=slot_name] --resources=list_of_jars
               (--module-xml=file_path |
                ([--dependencies=list_of_module_names]
                 [--properties=list_of_properties]
                 [--main-class=fully_qualified_class_name]])
               )


How reproducible:
Install a Jboss EAP and try to create a module with export dependencies

Steps to Reproduce:
1. Install Jboss EAP
2. Connecto to CLI console
3.  Try to create a new module with export=true option

Actual results:
Jboss CLI does not have that option

Expected results:
Add this capability to CLI for add modules.

Comment 5 Brad Maxwell 2016-09-16 20:55:46 UTC
Closing as this is a feature request not a bug. An RFE was opened


Note You need to log in before you can comment on or make changes to this bug.