Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367502 - tuned realtime profiles need rcu_nocbs
Summary: tuned realtime profiles need rcu_nocbs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned
Version: 7.2
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Tereza Cerna
URL:
Whiteboard:
Depends On: 1334479
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-16 14:34 UTC by Marcel Kolaja
Modified: 2016-09-15 08:00 UTC (History)
18 users (show)

Fixed In Version: tuned-2.5.1-4.el7_2.5
Doc Type: Bug Fix
Doc Text:
Previously, with the realtime-virtual-host and realtime-virtual-guest tuned profiles, the rcu_nocbs kernel parameter was missing from the /proc/cmdline file. With this update, rcu-nocbs is included as expected.
Clone Of: 1334479
Environment:
Last Closed: 2016-09-15 08:00:34 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1848 normal SHIPPED_LIVE tuned bug fix update 2016-09-15 11:34:59 UTC

Description Marcel Kolaja 2016-08-16 14:34:28 UTC
This bug has been copied from bug #1334479 and has been proposed
to be backported to 7.2 z-stream (EUS).

Comment 4 Tereza Cerna 2016-08-23 08:48:41 UTC
=============================================
Verified in:
    tuned-2.5.1-4.el7_2.5.noarch
    tuned-profiles-nfv-2.5.1-4.el7_2.5.noarch
PASS
=============================================

# cat /usr/lib/tuned/realtime-virtual-host/tuned.conf | grep cmdline
cmdline=isolcpus=${isolated_cores} nohz=on nohz_full=${isolated_cores} rcu_nocbs=${isolated_cores} intel_pstate=disable nosoftlockup
# cat /etc/tuned/realtime-virtual-host-variables.conf
isolated_cores=1
# tuned-adm profile realtime-virtual-host
# reboot
# cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-3.10.0-493.el7.x86_64 root=/dev/mapper/rhel_dell--pe--fm120--2c-root ro crashkernel=auto rd.lvm.lv=rhel_dell-pe-fm120-2c/root rd.lvm.lv=rhel_dell-pe-fm120-2c/swap console=ttyS0,115200n81 isolcpus=1 nohz=on nohz_full=1 rcu_nocbs=1 intel_pstate=disable nosoftlockup

The same behavior is also for realtime-virtual-guest.

=============================================
Reproduced in:
    tuned-2.5.1-7.el7.noarch
    tuned-profiles-nfv-2.5.1-7.el7.noarch
FAIL
=============================================

# cat /usr/lib/tuned/realtime-virtual-host/tuned.conf | grep cmdline
cmdline=isolcpus=${isolated_cores} nohz=on nohz_full=${isolated_cores} intel_pstate=disable nosoftlockup
# cat /etc/tuned/realtime-virtual-host-variables.conf
isolated_cores=1
# tuned-adm profile realtime-virtual-host
# reboot
# cat /proc/cmdline 
# cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-3.10.0-493.el7.x86_64 root=/dev/mapper/rhel_dell--pe--fm120--2c-root ro crashkernel=auto rd.lvm.lv=rhel_dell-pe-fm120-2c/root rd.lvm.lv=rhel_dell-pe-fm120-2c/swap console=ttyS0,115200n81 isolcpus=1 nohz=on nohz_full=1 intel_pstate=disable nosoftlockup

Comment 6 errata-xmlrpc 2016-09-15 08:00:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1848.html


Note You need to log in before you can comment on or make changes to this bug.