Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367483 - Installing a 3.6 host to rhev-m 4.0 results in 'ovirtmgmt' network as out of sync
Summary: Installing a 3.6 host to rhev-m 4.0 results in 'ovirtmgmt' network as out of ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: 4.0.2.6
Hardware: x86_64
OS: Linux
high
high vote
Target Milestone: ovirt-4.0.2
: 4.0.2.7
Assignee: Marcin Mirecki
QA Contact: Michael Burman
URL:
Whiteboard:
: 1365470 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-16 14:11 UTC by Michael Burman
Modified: 2016-08-22 12:32 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: 3.6 hosts do not report a switch type. Consequence: The switch type in engine is null. Fix: If 3.6 host does not report any switch type, it is considered that the host's switch type is LEGACY
Clone Of:
Environment:
Last Closed: 2016-08-22 12:32:03 UTC
oVirt Team: Network
rule-engine: ovirt-4.0.z+
rule-engine: blocker+
ylavi: planning_ack+
danken: devel_ack+
myakove: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 62380 master MERGED engine: Set default switchType if none is received from vdsm 2016-08-16 14:16:53 UTC
oVirt gerrit 62386 ovirt-engine-4.0 MERGED engine: Set default switchType if none is received from vdsm 2016-08-17 08:57:36 UTC
oVirt gerrit 62387 ovirt-engine-4.0.2 MERGED engine: Set default switchType if none is received from vdsm 2016-08-17 13:10:28 UTC

Description Michael Burman 2016-08-16 14:11:29 UTC
Description of problem:
Installing a 3.6 host to rhev-m 4.0 results in 'ovirtmgmt' network as out of sync.

Adding a 3.6 host to rhv-m 4.0 ends up with 'ovirtmgmt' network as out-of-sync cause of the switch type value that is missing on the host. 

How reproducible:
100

Additional info:
See also - BZ 1364787

Comment 1 Yaniv Lavi 2016-08-17 15:15:52 UTC
*** Bug 1365470 has been marked as a duplicate of this bug. ***

Comment 2 Michael Burman 2016-08-22 08:04:59 UTC
Verified on - 4.0.2.7-0.1.el7ev and vdsm-4.17.33-1.el7ev.noarch


Note You need to log in before you can comment on or make changes to this bug.