Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367457 - [RFE] Refactor the hosted-engine wizard UI to use alt2
Summary: [RFE] Refactor the hosted-engine wizard UI to use alt2
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Hosted Engine
Version: 0.11.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ovirt-4.2.0
: 0.11.0
Assignee: Phillip Bailey
QA Contact: Yihui Zhao
URL: https://trello.com/c/2ZxB3A74/314-des...
Whiteboard:
: 1462003 (view as bug list)
Depends On: 1376008 1509775 1516113 1516121
Blocks: 1379146 1451861
TreeView+ depends on / blocked
 
Reported: 2016-08-16 13:01 UTC by Fabian Deutsch
Modified: 2017-12-20 11:01 UTC (History)
20 users (show)

Fixed In Version: cockpit-ovirt-0.11.0-0.0.4.el7ev
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 11:01:43 UTC
oVirt Team: SLA
rule-engine: ovirt-4.2+
yzhao: testing_plan_complete+
mgoldboi: planning_ack+
fdeutsch: devel_ack+
ycui: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1497499 None None None Never
oVirt gerrit 82125 master MERGED wizard: Create new HE setup wizard UI 2017-10-05 12:18:48 UTC
oVirt gerrit 82561 ovirt-4.2 MERGED wizard: Create new HE setup wizard UI 2017-10-05 12:19:06 UTC
oVirt gerrit 82633 ovirt-4.2 MERGED wizard: Add input validation 2017-10-24 08:03:55 UTC

Internal Links: 1497499

Description Fabian Deutsch 2016-08-16 13:01:50 UTC
Description of problem:
The hosted engine wizard in Cockpit is functional, but UX wise a bit rough.

Two new designs were suggested, one of them should be implemented to improve the UX.

Comment 3 Red Hat Bugzilla Rules Engine 2016-09-22 10:18:31 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 4 Red Hat Bugzilla Rules Engine 2016-09-22 10:19:29 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 6 Sandro Bonazzola 2017-06-16 06:37:24 UTC
*** Bug 1462003 has been marked as a duplicate of this bug. ***

Comment 8 Yaniv Kaul 2017-10-15 08:54:09 UTC
Can this be moved to MODIFIED, or are there additional patches needed?

Comment 9 Phillip Bailey 2017-10-16 19:14:52 UTC
I was planning on moving it to MODIFIED once the validation patch [1] is merged.

[1] https://gerrit.ovirt.org/#/c/82633/

Comment 10 Yaniv Kaul 2017-10-26 11:29:43 UTC
(In reply to Phillip Bailey from comment #9)
> I was planning on moving it to MODIFIED once the validation patch [1] is
> merged.
> 
> [1] https://gerrit.ovirt.org/#/c/82633/

And now?

Comment 11 Phillip Bailey 2017-10-26 11:56:09 UTC
Done!

Comment 12 Yihui Zhao 2017-11-06 10:44:04 UTC
Due to the bug: https://bugzilla.redhat.com/show_bug.cgi?id=1509775, so need to assigned.

For the upstream build: ovirt-node-ng-4.2.0-0.20171031.0+1, I cannot found the changes for process of deploying HostedEngine.Could you help to check?

Comment 13 Phillip Bailey 2017-11-09 13:45:43 UTC
The changes will be in the cockpit-ovirt-dashboard package. The build of node you're referencing may not have the updated package included. If the old wizard is being displayed, this is definitely the case.

Comment 14 Yihui Zhao 2017-11-28 06:40:39 UTC
QE will verify this bug if the new build is available, and the bug 1516121, 1516113 should be verified before.

Comment 15 Yihui Zhao 2017-12-07 03:08:20 UTC
Now HostedEngine use alt2 wizard UI.

Test version:
cockpit-ovirt-dashboard-0.11.1-0.6.el7ev.noarch
rhvh-4.2.0.5-0.20171123.0+1
ovirt-host-4.2.0-0.1.master.el7ev.noarch
ovirt-host-deploy-1.7.0-0.2.master.git24e53fd.el7ev.noarch
ovirt-hosted-engine-setup-2.2.0-0.4.master.git0b67c21.el7ev.noarch
rhvm-appliance-4.2-20171102.0.el7.noarch


Test steps:
1. Clean install rhvh-4.2.0.5-0.20171123.0+1
2. Upgrade the cockpit-ovirt-dashboard pkg to cockpit-ovirt-dashboard-0.11.1-0.6.el7ev.noarch
3. Deploy the HostedEngine

Actual results:
HostedEngine use alt2 wizard UI.


So, change this bug's status to verified.

Comment 16 Sandro Bonazzola 2017-12-20 11:01:43 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.