Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367455 - No contacts are displayed until search is started
Summary: No contacts are displayed until search is started
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: evolution-mapi
Version: 7.3
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Milan Crha
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-16 12:57 UTC by Jiri Koten
Modified: 2016-11-04 00:26 UTC (History)
1 user (show)

Fixed In Version: evolution-mapi-3.12.10-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 00:26:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2206 normal SHIPPED_LIVE evolution-data-server bug fix update 2016-11-03 13:23:16 UTC

Description Jiri Koten 2016-08-16 12:57:20 UTC
Description of problem:
No contacts are displayed in Contacts addressbook on Exchange 2007 server using MAPI backend. I have to invoke search to get the contacts to show up. After that the contacts are shown until next evolution start.
 
$ evolution
openjdk version "1.8.0_102"
OpenJDK Runtime Environment (build 1.8.0_102-b14)
OpenJDK 64-Bit Server VM (build 25.102-b14, mixed mode)

(evolution:27702): eab-widgets-CRITICAL **: ea_minicard_view_get_name: assertion 'E_IS_BOOK_CLIENT (book_client)' failed


Version-Release number of selected component (if applicable):
evolution-3.12.11-21.el7
evolution-data-server-3.12.11-34.el7
evolution-mapi-3.12.10-4.el7

How reproducible:
100%

Steps to Reproduce:
1. Create MAPI account
2. Go to Contacts view and choose Contacts addressbook on exchange server.


Actual results:
No contacts are displayed, until search is started

Expected results:
Contacts should be visible right away

Additional info:

Comment 1 Milan Crha 2016-08-16 15:30:48 UTC
Thanks for a bug report and a good catch. It requires to have the book marked for offline, though I realized that the offline state wasn't recognized before the book was opened, which caused this misbehaviour also for the books marked for offline. I fixed it upstream for 3.21.91+:
https://git.gnome.org/browse/evolution-mapi/commit/?id=7b30258

Comment 5 errata-xmlrpc 2016-11-04 00:26:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2206.html


Note You need to log in before you can comment on or make changes to this bug.