Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367448 - [RFE] Change default values for filestore split/merge
Summary: [RFE] Change default values for filestore split/merge
Keywords:
Status: CLOSED DUPLICATE of bug 1219974
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS
Version: 1.3.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: 2.1
Assignee: Josh Durgin
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-16 12:33 UTC by Vikhyat Umrao
Modified: 2017-07-30 15:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-17 17:59:26 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 17043 None None None 2016-08-16 12:36:44 UTC
Red Hat Bugzilla 1219974 None CLOSED [RFE] filestore merge threadhold and split multiple defaults may not be ideal 2019-03-07 14:12:26 UTC

Internal Links: 1219974

Description Vikhyat Umrao 2016-08-16 12:33:16 UTC
Description of problem:

[RFE] Change default values for filestore split/merge 

In recent customer cases we have seen keeping default value 320 is good but for getting number 320 is better to have:

filestore merge threshold = 1 
filestore split multiple = 20 

This will prevent merging of directories.

Current defaults are:

http://docs.ceph.com/docs/master/rados/configuration/filestore-config-ref/#misc

filestore merge threshold = 10 
filestore split multiple = 2


Version-Release number of selected component (if applicable):
Red Hat Ceph Storage 1.3.2

Comment 1 Vikhyat Umrao 2016-08-17 17:59:26 UTC

*** This bug has been marked as a duplicate of bug 1219974 ***


Note You need to log in before you can comment on or make changes to this bug.