Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367379 - For service without deployment, associated DC is not shown on project overview page
Summary: For service without deployment, associated DC is not shown on project overvie...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-16 10:07 UTC by Yadan Pei
Modified: 2017-03-08 18:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Previously, we did not show the deployment config on the overview page when it hadn't run a deployment yet. Now we should a tile for the deployment config. If the deployment config has an image change trigger, we show a link to the image stream whose tag it will trigger on.
Clone Of:
Environment:
Last Closed: 2017-01-18 12:52:24 UTC


Attachments (Terms of Use)
ServiceWithoutDeployments (deleted)
2016-08-16 10:08 UTC, Yadan Pei
no flags Details
ServiceWithDeployments (deleted)
2016-08-16 10:09 UTC, Yadan Pei
no flags Details
3.2 no deployment config (deleted)
2016-08-16 14:15 UTC, Jessica Forrester
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0066 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.4 RPM Release Advisory 2017-01-18 17:23:26 UTC

Description Yadan Pei 2016-08-16 10:07:28 UTC
Description of problem:
For service without deployment, associated DC is not shown on project overview page

Version-Release number of selected component (if applicable):
v3.3.0.19

How reproducible:
Always

Steps to Reproduce:
1. Create a project 
2. Add to Project -> Deploy Image
3. Set Image Stream Tag, take openshift/mongodb:2.6 as an example in this issue
4. Hit on "Create"
5. dc/mongodb and svc/mongodb will be created, but deployment could not be created successfully due to known issue at https://bugzilla.redhat.com/show_bug.cgi?id=1355976
6. Check project overview page

Actual results:
6. DC/mongodb is not shown on overview page(refer to attachment)


Expected results:
6. Althrough DC/mongodb has no deployments, Service: mongodb and Deployment: mongodb should still be shown and grouped

Additional info:

Comment 1 Yadan Pei 2016-08-16 10:08:48 UTC
Created attachment 1191187 [details]
ServiceWithoutDeployments

Comment 2 Yadan Pei 2016-08-16 10:09:16 UTC
Created attachment 1191188 [details]
ServiceWithDeployments

Comment 3 Jessica Forrester 2016-08-16 14:14:26 UTC
This is the same behavior we have had in all the previous 3.x releases, attaching a 3.2 screenshot for reference.  We would like to improve it but this is not a regression and the fix is a significant change.

Comment 4 Jessica Forrester 2016-08-16 14:15:08 UTC
Created attachment 1191298 [details]
3.2 no deployment config

Comment 5 Yadan Pei 2016-08-17 01:04:57 UTC
Ok, that make sense to me

Comment 7 Troy Dawson 2016-10-31 18:14:34 UTC
This has been merged into ose and is in OSE v3.4.0.18 or newer.

Comment 9 Yadan Pei 2016-11-01 06:07:35 UTC
Checked against v3.4.0.18+ada983f with reproduce steps, now DC is shown on overview. Also when DC has no deployment started, there is message "No deployments, A new deployment will start automatically when...." 


Move to VERIFIED

Comment 11 errata-xmlrpc 2017-01-18 12:52:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0066


Note You need to log in before you can comment on or make changes to this bug.