Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367367 - Service skyring should be stopped during uninstallation process
Summary: Service skyring should be stopped during uninstallation process
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: distribution
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3
Assignee: Nishanth Thomas
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-16 09:38 UTC by Daniel Horák
Modified: 2017-03-23 04:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-23 04:05:32 UTC


Attachments (Terms of Use)

Description Daniel Horák 2016-08-16 09:38:36 UTC
Description of problem:
  Service skyring remains running, when rhscon-core is uninstalled.

Version-Release number of selected component (if applicable):
  rhscon-core-0.0.41-1.el7scon.x86_64

How reproducible:
  100%

Steps to Reproduce:
1. Install rhscon-core with all required dependences.
  # yum install rhscon-core rhscon-ui rhscon-ceph
2. Start skyring service and check if it is running.
  # systemctl start skyring
  # systemctl status skyring
3. Uninstall rhscon-core package (and all other previously installed packages).
  # yum remove ansible carbon-selinux ceph-ansible ceph-installer erlang-asn1 erlang-compiler erlang-crypto erlang-erts erlang-hipe erlang-inets erlang-kernel erlang-mnesia erlang-os_mon erlang-otp_mibs erlang-public_key erlang-runtime_tools erlang-sasl erlang-sd_notify erlang-snmp erlang-ssl erlang-stdlib erlang-syntax_tools erlang-tools erlang-xmerl graphite-web mongodb mongodb-server openpgm pyserial python-amqp python-anyjson python-billiard python-carbon python-celery python-cpopen python-crypto python-django python-django-bash-completion python-django-tagging python-ecdsa python-gunicorn python-httplib2 python-jinja2 python-keyczar python-kombu python-logutils python-msgpack python-notario python-paramiko python-pecan python-pecan-notario python-simplegeneric python-simplejson python-singledispatch python-tambo python-twisted-core python-webob python-webtest python-whisper python-zmq python-zope-interface rabbitmq-server rhscon-ceph rhscon-core rhscon-core-selinux rhscon-ui salt salt-master salt-selinux sshpass v8 zeromq3
4. Check the status of skyring service
  # systemctl status skyring
  
Actual results:
  Skyring is still running, even when it is uninstalled.
  # systemctl status skyring
  ● skyring.service
     Loaded: not-found (Reason: No such file or directory)
     Active: active (running) since Tue 2016-08-16 11:33:56 CEST; 3min 25s ago
   Main PID: 6994 (skyring)
     CGroup: /system.slice/skyring.service
             ├─6994 /usr/bin/skyring --log-level INFO
             └─7009 /var/lib/skyring/providers/bigfin eyJjb25maWciOnsiaG9zdCI6IjAuMC4wLjAiLCJodHRwUG9ydCI6ODA4MCwic3NsRW5hYmxlZCI6ZmFsc2UsInNzbFBvcnQiOjEwNDQzLCJzc2xDZXJ0IjoiL2V0Yy9wa2kvdGxzL3NreXJpbmcuY3J0Iiwic3NsS2V5IjoiL2V0Yy9wa2kvdG...
  
  Aug 16 11:33:56 dhcp-126-86.lab.eng.brq.redhat.com systemd[1]: Starting Skyring Daemon...
  Aug 16 11:33:56 dhcp-126-86.lab.eng.brq.redhat.com systemd[1]: Started Skyring Daemon.
  Aug 16 11:33:57 dhcp-126-86.lab.eng.brq.redhat.com skyring[6994]: 2016-08-16T11:33:57.15+02:00 INFO     main.go:213 start] Starting the providers
  Aug 16 11:33:57 dhcp-126-86.lab.eng.brq.redhat.com skyring[6994]: 2016-08-16T11:33:57.151+02:00 INFO     skyring.go:99 StartProviders] Config:%!(EXTRA []conf.ProviderInfo=[{{ceph bigfin 10.1} [] {ceph-installer  true fa...n_cluster:3]}])
  Aug 16 11:33:57 dhcp-126-86.lab.eng.brq.redhat.com skyring[6994]: 2016-08-16T11:33:57.154+02:00 INFO     main.go:220 start] Starting event listener
  Aug 16 11:33:57 dhcp-126-86.lab.eng.brq.redhat.com skyring[6994]: 2016-08-16T11:33:57.158+02:00 INFO     broadcaster.go:61 func2] Websocket - start listening on 0.0.0.0 : 8081
  Aug 16 11:33:57 dhcp-126-86.lab.eng.brq.redhat.com skyring[6994]: 2016-08-16T11:33:57.158+02:00 INFO     main.go:151 func2] Started listening on 0.0.0.0:8080
  Hint: Some lines were ellipsized, use -l to show in full.
  

Expected results:
  Service skyring should be stopped during uninstallation process.

Additional info:


Note You need to log in before you can comment on or make changes to this bug.