Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367362 - Log EEXIST errors at DEBUG level
Summary: Log EEXIST errors at DEBUG level
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: posix
Version: 3.7.14
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Krutika Dhananjay
QA Contact:
URL:
Whiteboard:
Depends On: 1367258 1367363
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-16 09:26 UTC by Krutika Dhananjay
Modified: 2016-09-01 09:33 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.7.15
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1367258
Environment:
Last Closed: 2016-09-01 09:22:29 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Krutika Dhananjay 2016-08-16 09:26:33 UTC
+++ This bug was initially created as a clone of Bug #1367258 +++

Description of problem:

Often, multiple io-threads could be attempting to create a shard at the same time, causing one of those attempts to fail with EEXIST. This is being logged at ERROR level today. It can be suppressed by moving it to DEBUG.

See http://www.gluster.org/pipermail/gluster-users/2016-August/028039.html for more information.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2016-08-16 01:19:27 EDT ---

REVIEW: http://review.gluster.org/15161 (storage/posix: Log EEXIST failures at DEBUG log-level) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-08-16 05:24:52 EDT ---

COMMIT: http://review.gluster.org/15161 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 020c39e8ab657fbf12c102186c14aca24239efd4
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Tue Aug 16 10:43:07 2016 +0530

    storage/posix: Log EEXIST failures at DEBUG log-level
    
    Change-Id: I56f160058d2e2751ca75f1f75ea8254a1b8a6bf3
    BUG: 1367258
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/15161
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 1 Vijay Bellur 2016-08-16 09:28:24 UTC
REVIEW: http://review.gluster.org/15174 (storage/posix: Log EEXIST failures at DEBUG log-level) posted (#1) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)

Comment 2 Vijay Bellur 2016-08-17 10:22:37 UTC
COMMIT: http://review.gluster.org/15174 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 0215d1df7cedf7ca54cf96d2a09a68b294cf9459
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Tue Aug 16 10:43:07 2016 +0530

    storage/posix: Log EEXIST failures at DEBUG log-level
    
            Backport of: http://review.gluster.org/15161
    
    Change-Id: I98faa1170dae89879f678e8836f499bbc6ace675
    BUG: 1367362
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/15174
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 3 Kaushal 2016-09-01 09:22:29 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.15, please open a new bug report.

glusterfs-3.7.15 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-September/050714.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 4 Kaushal 2016-09-01 09:33:49 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.15, please open a new bug report.

glusterfs-3.7.15 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-September/050714.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.