Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367318 - Emails from releases have jenkins@build.gluster.org as "from" address
Summary: Emails from releases have jenkins@build.gluster.org as "from" address
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-16 08:14 UTC by Niels de Vos
Modified: 2017-05-21 03:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-21 03:35:38 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)
Email that bounced and got back into my inbox (deleted)
2016-08-16 08:17 UTC, Niels de Vos
no flags Details

Description Niels de Vos 2016-08-16 08:14:55 UTC
Description of problem:
Emails from the release job in Jenkins ( https://build.gluster.org/job/release/ ) have jenkins@build.gluster.org as "from" address. Because the release emails are used by the packagers to reply when the packages are available, many packagers receive bounce mails (when they just reply-all).

Please change the from-address for Jenkins jobs to an address that silently accepts (and disregards?) replies.

Comment 1 Niels de Vos 2016-08-16 08:17:03 UTC
Created attachment 1191135 [details]
Email that bounced and got back into my inbox

Comment 2 M. Scherer 2016-08-16 08:34:06 UTC
Another solution is to put a ReplyTo header on the mail, i guess ?

And where do packager reply, ie, does it go to gluster-devel, etc ?

Comment 3 Niels de Vos 2016-08-16 10:50:02 UTC
(In reply to M. Scherer from comment #2)
> Another solution is to put a ReplyTo header on the mail, i guess ?
> 
> And where do packager reply, ie, does it go to gluster-devel, etc ?

That depends a bit on the job. The release ones go to the maintainers and packagers list. Others are to the maintainers only (I think).

Comment 4 Nigel Babu 2017-05-21 03:35:38 UTC
I recommend that release maintainers do the extra work of removing a From. I don't think that's too much of an ask.


Note You need to log in before you can comment on or make changes to this bug.