Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367255 - Fedora Live: Plymouth does not read LUKS password at boot. Encrypted /home is unusable
Summary: Fedora Live: Plymouth does not read LUKS password at boot. Encrypted /home is...
Alias: None
Product: Fedora
Classification: Fedora
Component: plymouth
Version: 24
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2016-08-16 04:27 UTC by rmhristev
Modified: 2017-08-08 16:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2017-08-08 16:34:09 UTC

Attachments (Terms of Use)

Description rmhristev 2016-08-16 04:27:00 UTC
Description of problem:

Fedora Live USB stick with encrypted /home:
The system asks for password but is unable to read it from the console.

Version-Release number of selected component (if applicable):

Since Fedora 18 (incl). The last version where it worked was Fedora 17
(i.e. Fedora 18, 19, 20, 21, 22, 23, 24 -- are all affected)

How reproducible:


Steps to Reproduce:
1. Build a USB live stick with

livecd-iso-to-disk --overlay-size-mb <N> --home-size-mb <NN> <LIVE.iso> <PARTITION>

2. boot USB

sudo qemu-kvm -drive file=/dev/sd<X>,format=raw -m 2048 -usbdevice tablet -soundhw ac97

Actual results:

Hangs soon after boot, asking for password and waiting forever. Does not seem to actually read the keyboard input.

Expected results:

Read password from keyboard, decrypt home, finish boot

Additional info:

Without an encrypted /home, the live system has limited use, only as installation media and basic troubleshooting.

The ability to use it as a system on the go is essentially lost because the risk of losing an unencrypted USB stick with personal data is too great.

I did post about this bug once or twice in the past but it was closed as the Fedora version went out of support.

Thank you for your attention.

Comment 1 jlcd 2016-10-14 08:14:10 UTC
I have the same issue, but with a custom Live USB of fedora XFCE. As far as I know, it is caused by plymouth-quit service, which starts before you finish typing your password, so the input box dissapears and "plymouth ask-for-password" stops getting input from keyboard, although being still running.

For new live images, edit /usr/share/spin-kickstarts/fedora-live-base.ks on the host system and append "plymouth-quit" to the livesys service X-Start-Before list:

# X-Start-Before: display-manager chronyd plymouth-quit

With that, it generates a working live ISO the next time (I tested it). In already existing live images (with persistence overlay), edit /etc/rc.d/init.d/livesys (go to another tty and login as root). After rebooting, it should work (I didn't test it).

Comment 2 rmhristev 2016-12-04 22:56:22 UTC
Many thanks jlcd :-)

I use livecd-iso-to-disk and it looks like it ignored /usr/share/spin-kickstarts/fedora-live-base.ks

But after building the USB, I was able to boot in single mode and edit /etc/rc.d/init.d/livesys

It worked even if some systemd jobs are clobbering the output and the password has to be typed blindly.

It's a workaround that I can live with for the time being.


Comment 3 Fedora End Of Life 2017-07-25 22:27:14 UTC
This message is a reminder that Fedora 24 is nearing its end of life.
Approximately 2 (two) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 24. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '24'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 24 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 4 Fedora End Of Life 2017-08-08 16:34:09 UTC
Fedora 24 changed to end-of-life (EOL) status on 2017-08-08. Fedora 24 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.