Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367248 - Installing guest os failed with RHEL-7.3-20160811.0 ppc64le iso file
Summary: Installing guest os failed with RHEL-7.3-20160811.0 ppc64le iso file
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: binutils
Version: 7.3
Hardware: ppc64le
OS: Linux
urgent
urgent
Target Milestone: rc
: 7.3
Assignee: Nick Clifton
QA Contact: qe-baseos-tools
URL:
Whiteboard:
: 1368380 (view as bug list)
Depends On:
Blocks: 1256306
TreeView+ depends on / blocked
 
Reported: 2016-08-16 03:21 UTC by Xujun Ma
Modified: 2017-02-09 08:56 UTC (History)
29 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-09 10:27:19 UTC


Attachments (Terms of Use)
failed log (deleted)
2016-08-16 03:21 UTC, Xujun Ma
no flags Details
the kickstart file during installation (deleted)
2016-08-26 11:40 UTC, IBM Bug Proxy
no flags Details
the tar archive of "/tmp" inside failed anaconda, which includes any anaconda logs (deleted)
2016-08-26 11:40 UTC, IBM Bug Proxy
no flags Details
the output of "journalctl -u NetworkManager -o verbose" inside anaconda (deleted)
2016-08-26 11:41 UTC, IBM Bug Proxy
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1368380 None None None Never
Red Hat Bugzilla 1369937 None None None Never
Red Hat Bugzilla 1370174 None None None Never

Internal Links: 1368380

Description Xujun Ma 2016-08-16 03:21:31 UTC
Created attachment 1191047 [details]
failed log

Description of problem:
Installing guest os failed with RHEL-7.3-20160811.0 iso file

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Install guest os with command
MALLOC_PERTURB_=1  /usr/libexec/qemu-kvm \
    -S  \
    -name 'avocado-vt-vm1'  \
    -sandbox off  \
    -machine pseries  \
    -nodefaults  \
    -vga std  \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/var/tmp/avocado_xm3Ufn/monitor-qmpmonitor1-20160815-025049-ZauRpQir,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control  \
    -chardev socket,id=qmp_id_catch_monitor,path=/var/tmp/avocado_xm3Ufn/monitor-catch_monitor-20160815-025049-ZauRpQir,server,nowait \
    -mon chardev=qmp_id_catch_monitor,mode=control  \
    -chardev socket,id=serial_id_serial0,path=/var/tmp/avocado_xm3Ufn/serial-serial0-20160815-025049-ZauRpQir,server,nowait \
    -device spapr-vty,reg=0x30000000,chardev=serial_id_serial0 \
    -device pci-ohci,id=usb1,bus=pci.0,addr=03 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pci.0,addr=04,disable-legacy=off,disable-modern=on \
    -drive id=drive_image1,if=none,snapshot=off,aio=threads,cache=none,format=qcow2,file=/usr/share/avocado/data/avocado-vt/images/RHEL-Server-7.3-ppc64-virtio-scsi.qcow2 \
    -device scsi-hd,id=image1,drive=drive_image1 \
    -device virtio-net-pci,mac=9a:11:12:13:14:15,id=idexGpQT,vectors=4,netdev=id7KLkyh,bus=pci.0,addr=05,disable-legacy=off,disable-modern=on  \
    -netdev tap,id=id7KLkyh,vhost=on,vhostfd=20,fd=19 \
    -m 8192  \
    -smp 4,maxcpus=4,cores=2,threads=1,sockets=2 \
    -drive id=drive_cd1,if=none,snapshot=off,aio=threads,cache=none,media=cdrom,file=/usr/share/avocado/data/avocado-vt/isos/linux/RHEL7.3-Server-ppc64.iso \
    -device scsi-cd,id=cd1,drive=drive_cd1 \
    -drive id=drive_unattended,if=none,snapshot=off,aio=threads,cache=none,media=cdrom,file=/usr/share/avocado/data/avocado-vt/images/rhel73-ppc64/ks.iso \
    -device scsi-cd,id=unattended,drive=drive_unattended \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -kernel '/usr/share/avocado/data/avocado-vt/images/rhel73-ppc64/vmlinuz'  \
    -append 'ksdevice=link inst.repo=cdrom:/dev/sr0 inst.ks=cdrom:/dev/sr1:/ks.cfg nicdelay=60 console=ttyS0,115200 console=tty0 biosdevname=0 net.ifnames=0'  \
    -initrd '/usr/share/avocado/data/avocado-vt/images/rhel73-ppc64/initrd.img'  \
    -vnc :0  \
    -rtc base=utc,clock=host  \
    -boot order=cdn,once=d,menu=off,strict=off  \
    -no-shutdown \
    -enable-kvm

2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Qunfang Zhang 2016-08-16 03:25:23 UTC
Since previous 20160729.1 compose does not hit it, so mark a Regression keyword.

Comment 6 Gu Nini 2016-08-16 07:27:32 UTC
For x86_64 test, the same case passed without the bug problem.

Comment 10 Radek Vykydal 2016-08-16 12:09:54 UTC
I need to see also /tmp/syslog (or boot options used) and output of "journalctl -u NetworkManager" (NM logging into /tmp/syslog is broken: bug 1358335). Please attach the logs together with /tmp/ifcfg.log and /tmp/anaconda.log if you run another instance of reproducer.

Also the same logs from successful 20160729.1 could be helpful.

Doesn't seem like is should be caused by any change in anaconda between 0729 and 0811. I am not sure about NM but I'd need to see the requested log (output of journalctl -u NetworkManager).

Comment 13 Samantha N. Bueno 2016-08-17 04:07:44 UTC
Hi Xu,

Can you try testing this without MALLOC_PERTURB set and let us know whether the bug still occurs?

I know it's commonly used in testing to unearth some of the more subtle bugs, but users are most likely not going to be trying to install with this var set.

Comment 14 Xu Han 2016-08-17 05:06:45 UTC
(In reply to Samantha N. Bueno from comment #13)
> Hi Xu,
> 
> Can you try testing this without MALLOC_PERTURB set and let us know whether
> the bug still occurs?

This bug can be reproduced without MALLOC_PERTURB set.

Comment 15 Radek Vykydal 2016-08-17 12:52:48 UTC
This seems to be the root cause (nm.log form comment#11):

Aug 17 02:43:39 localhost NetworkManager[2076]: <warn>  [1471401819.0281] settings: could not load plugin 'ifcfg-rh' from file '/usr/lib64/NetworkManager/libnm-settings-plugin-ifcfg-rh.so': /usr/lib64/NetworkManager/libnm-settings-plugin-ifcfg-rh.so: undefined symbol: nm_setting_dcb_set_priority_flow_control

Comment 16 Lubomir Rintel 2016-08-22 16:09:24 UTC
(In reply to Radek Vykydal from comment #15)
> This seems to be the root cause (nm.log form comment#11):
> 
> Aug 17 02:43:39 localhost NetworkManager[2076]: <warn>  [1471401819.0281]
> settings: could not load plugin 'ifcfg-rh' from file
> '/usr/lib64/NetworkManager/libnm-settings-plugin-ifcfg-rh.so':
> /usr/lib64/NetworkManager/libnm-settings-plugin-ifcfg-rh.so: undefined
> symbol: nm_setting_dcb_set_priority_flow_control

We link with "-fdata-sections -ffunction-sections -Wl,--gc-sections".

The symbol was incorrectly dropped; but not in the subsequent build that used newer binutils package:

@@ -70,14 +70,14 @@ DEBUG util.py:417:   xz
 DEBUG util.py:417:  Installing for dependencies:
 DEBUG util.py:417:   audit-libs                 ppc64le     2.4.1-5.el7             build      79 k
 DEBUG util.py:417:   basesystem                 noarch      10.0-7.el7              build     3.8 k
-DEBUG util.py:417:   binutils                   ppc64le     2.25.1-22.base.el7      build     3.4 M
+DEBUG util.py:417:   binutils                   ppc64le     2.23.52.0.1-55.el7      build     3.1 M
 DEBUG util.py:417:   bzip2-libs                 ppc64le     1.0.6-13.el7            build      47 k
 DEBUG util.py:417:   ca-certificates            noarch      2015.2.6-73.el7         build     427 k
 DEBUG util.py:417:   chkconfig                  ppc64le     1.7.2-1.el7             build     175 k

I presume this was fixed in current binutils; reassigning for binutils maintainers to verify.

Comment 17 Nick Clifton 2016-08-22 16:35:30 UTC
(In reply to Lubomir Rintel from comment #16)

> We link with "-fdata-sections -ffunction-sections -Wl,--gc-sections".

> -DEBUG util.py:417:   binutils                   ppc64le    
> 2.25.1-22.base.el7      build     3.4 M

> I presume this was fixed in current binutils; reassigning for binutils
> maintainers to verify.

This is almost certainly the case.  Without a lot of investigation it is hard to be sure, but I suspect that the fix came about as part of the patches for FSF binutils PR 17615:

  https://sourceware.org/bugzilla/show_bug.cgi?id=17615#c20 
 

Since the problem is fixed with the newer binutils rpm, can this BZ be closed now ?

Comment 19 Hanns-Joachim Uhl 2016-08-26 08:38:04 UTC
(In reply to Nick Clifton from comment #17)
> (In reply to Lubomir Rintel from comment #16)
> 
> > We link with "-fdata-sections -ffunction-sections -Wl,--gc-sections".
> 
> > -DEBUG util.py:417:   binutils                   ppc64le    
> > 2.25.1-22.base.el7      build     3.4 M
> 
> > I presume this was fixed in current binutils; reassigning for binutils
> > maintainers to verify.
> 
> This is almost certainly the case.  Without a lot of investigation it is
> hard to be sure, but I suspect that the fix came about as part of the
> patches for FSF binutils PR 17615:
> 
>   https://sourceware.org/bugzilla/show_bug.cgi?id=17615#c20 
>  
> 
> Since the problem is fixed with the newer binutils rpm, can this BZ be
> closed now ?
.
Hello Red Hat / Nick,
... will this 'newer binutils rpm' be included 
in the coming RHEL7.3 Snapshot 1 ..?
Please confirm or advise ...
Thanks in advance for your support.

Comment 20 Radek Vykydal 2016-08-26 11:21:21 UTC
*** Bug 1370174 has been marked as a duplicate of this bug. ***

Comment 21 IBM Bug Proxy 2016-08-26 11:40:39 UTC
Created attachment 1194311 [details]
the kickstart file during installation

Comment 22 IBM Bug Proxy 2016-08-26 11:40:52 UTC
Created attachment 1194312 [details]
the tar archive of "/tmp" inside failed anaconda, which includes any anaconda logs

Comment 23 IBM Bug Proxy 2016-08-26 11:41:04 UTC
Created attachment 1194313 [details]
the output of "journalctl -u NetworkManager -o verbose" inside  anaconda

Comment 24 Hanns-Joachim Uhl 2016-08-26 11:52:06 UTC
(In reply to Hanns-Joachim Uhl from comment #19)
> (In reply to Nick Clifton from comment #17)
> > (In reply to Lubomir Rintel from comment #16)
> > 
> > > We link with "-fdata-sections -ffunction-sections -Wl,--gc-sections".
> > 
> > > -DEBUG util.py:417:   binutils                   ppc64le    
> > > 2.25.1-22.base.el7      build     3.4 M
> > 
> > > I presume this was fixed in current binutils; reassigning for binutils
> > > maintainers to verify.
> > 
> > This is almost certainly the case.  Without a lot of investigation it is
> > hard to be sure, but I suspect that the fix came about as part of the
> > patches for FSF binutils PR 17615:
> > 
> >   https://sourceware.org/bugzilla/show_bug.cgi?id=17615#c20 
> >  
> > 
> > Since the problem is fixed with the newer binutils rpm, can this BZ be
> > closed now ?
> .
> Hello Red Hat / Nick,
> ... will this 'newer binutils rpm' be included 
> in the coming RHEL7.3 Snapshot 1 ..?
> Please confirm or advise ...
> Thanks in advance for your support.

... or let ask the other way around:
.
- RHEL7.3 Alpha is containing
  "binutils-2.25.1-20.base.el7.src.rpm 	23075 KB 27.06.2016 	15:31:00"
  ... with which this issue was not occurring ...
.
- RHEL7.3 Beta is containing
  "binutils-2.25.1-22.base.el7.src.rpm 	23104 KB 11.08.2016 	01:01:00"
  ... with which this issue is occurring ... 
 
i.e. which is the binutils version with which this issue 
is no longer occurring ...?
Please advise ...

Comment 26 Joseph Kachuck 2016-08-26 17:16:32 UTC
Hello Xujun,
Are you able to recreate this issue on RHEL 7.3 Beta?

Thank You
Joe Kachuck

Comment 27 Xujun Ma 2016-08-29 03:15:13 UTC
Hi joseph

I have no ppc host right now,and I'm reserving one.

I will retest it with RHEL 7.3 Beta when I get a host.

Comment 31 Xujun Ma 2016-08-30 06:20:08 UTC
RHEL7.3 Beta build still has this problem , but RHEL7.3 Snap 1 has no this problem with the same version of binutils:binutils-2.25.1-22.base.el7.ppc64le.rpm

Comment 32 Xujun Ma 2016-08-30 06:32:26 UTC
please ignore the changing of stauts.

Comment 34 Nick Clifton 2016-08-30 08:27:33 UTC
(In reply to Xujun Ma from comment #31)

> RHEL7.3 Beta build still has this problem , but RHEL7.3 Snap 1 has no this
> problem with the same version of
> binutils:binutils-2.25.1-22.base.el7.ppc64le.rpm

Were both releases built with the same binutils rpm in the buildroot ?
If so then this result is very confusing, since it would imply that the
binutils are not the cause of the problem, but that something else is responsible.  (Probably the version of the NetworkManager being built in the two tests).

Cheers
  Nick

Comment 37 Nick Clifton 2016-08-30 09:48:52 UTC
 (In reply to Hanns-Joachim Uhl from comment #24)

> - RHEL7.3 Alpha is containing
>   "binutils-2.25.1-20.base.el7.src.rpm 	23075 KB 27.06.2016 	15:31:00"
>   ... with which this issue was not occurring ...
> .
> - RHEL7.3 Beta is containing
>   "binutils-2.25.1-22.base.el7.src.rpm 	23104 KB 11.08.2016 	01:01:00"
>   ... with which this issue is occurring ... 

Are you able to test RHEL 7.3 Snap 1 ?  If so, does the problem still exist there ?

This is beginning to look like a transient problem with the RHEL 7.3 Beta release, and if we can agree that the problem is restricted to just that release then we can close this BZ.

Comment 39 Matt Newsome 2016-09-09 10:27:19 UTC
(In reply to Nick Clifton from comment #37)
> Are you able to test RHEL 7.3 Snap 1 ?  If so, does the problem still exist
> there ?
> 
> This is beginning to look like a transient problem with the RHEL 7.3 Beta
> release, and if we can agree that the problem is restricted to just that
> release then we can close this BZ.

I'm going to close out this bug on the understanding that it is indeed fixed in 7.3 beta snapshot 1. Looking at the current nightly compose of 7.3 beta, I see binutils-2.25.1-22.base.el7.ppc64le.rpm, which seems to match expectations.

Hanns-Joachim, if you're still seeing any kind of issue with this build, please re-open this bug with details. I'm going to close this bug on the understanding that this is now resolved, but we're happy to take a look at anything you're seeing. Thanks.

Comment 40 Hanns-Joachim Uhl 2016-09-09 10:47:39 UTC
(In reply to Matt Newsome from comment #39)
> (In reply to Nick Clifton from comment #37)
> > Are you able to test RHEL 7.3 Snap 1 ?  If so, does the problem still exist
> > there ?
> > 
> > This is beginning to look like a transient problem with the RHEL 7.3 Beta
> > release, and if we can agree that the problem is restricted to just that
> > release then we can close this BZ.
> 
> I'm going to close out this bug on the understanding that it is indeed fixed
> in 7.3 beta snapshot 1. Looking at the current nightly compose of 7.3 beta,
> I see binutils-2.25.1-22.base.el7.ppc64le.rpm, which seems to match
> expectations.
> 
> Hanns-Joachim, if you're still seeing any kind of issue with this build,
> please re-open this bug with details. I'm going to close this bug on the
> understanding that this is now resolved, but we're happy to take a look at
> anything you're seeing. Thanks.
.
... fully agreed upon ... thanks for your attention ...

Comment 41 Radek Vykydal 2016-11-18 10:34:47 UTC
*** Bug 1368380 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.