Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367234 - smartmontools fails to update drive DB.
Summary: smartmontools fails to update drive DB.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: smartmontools
Version: 6.8
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Michal Hlavinka
QA Contact: Vaclav Danek
URL:
Whiteboard:
Depends On: 1364830
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-16 02:04 UTC by Keigo Noha
Modified: 2017-03-21 11:13 UTC (History)
6 users (show)

Fixed In Version: smartmontools-5.43-3.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1364830
Environment:
Last Closed: 2017-03-21 11:13:46 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0724 normal SHIPPED_LIVE smartmontools bug fix update 2017-03-21 12:42:36 UTC

Description Keigo Noha 2016-08-16 02:04:41 UTC
+++ This bug was initially created as a clone of Bug #1364830 +++

Description of problem:
The current package version is 6.2 which uses HTTP for updating drive databases.
Sourceforge uses https but curl does not follow the redirect from http to https.

Version-Release number of selected component (if applicable):
6.2

How reproducible:
easily

Steps to Reproduce:
1. run /usr/sbin/update-smart-drivedb
2. see error message "/usr/sbin/update-smart-drivedb: download from trunk failed (HTTP error)"

Actual results:
Update failed

Expected results:
Update succeed

Additional info:
The problem was fixed in version 6.5, which was released 07.05.2016 but RedHat and Centos repos still contain v6.2

--- Additional comment from RHEL Product and Program Management on 2016-08-07 21:58:10 EDT ---

Since this bug report was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 1 Keigo Noha 2016-08-16 02:05:33 UTC
The issue occurs on RHEL6 latest smartmontools also.
The URL need to be updated.

Comment 2 Keigo Noha 2016-08-16 02:14:21 UTC
update-smart-drivedb shell script can not accept the latest drivedb.h.
The valid drivedb is https://sourceforge.net/p/smartmontools/code/HEAD/tree/tags/RELEASE_5_43/smartmontools/drivedb.h?format=raw

Comment 5 Christian Franke 2016-10-08 12:09:50 UTC
(In reply to Keigo Noha from comment #2)
> The valid drivedb is
> https://sourceforge.net/p/smartmontools/code/HEAD/tree/tags/RELEASE_5_43/
> smartmontools/drivedb.h?format=raw

This would downgrade drivedb.h to the original version from the 5.43 source tarball. Please use the branch URL instead:

https://sourceforge.net/p/smartmontools/code/HEAD/tree/branches/RELEASE_5_43_DRIVEDB/smartmontools/drivedb.h?format=raw

See also:
https://www.smartmontools.org/wiki/Download#Updatethedrivedatabase

The current (reworked) update script allows to select alternative URLs (SVN, Sourceforge, Trac). This script could be used also for older releases if BRANCH is set accordingly:

$ ./configure --with-PACKAGE_SPECIFIC_SETTINGS
$ make update-smart-drivedb
$ sed -i 's,RELEASE_.*_DRIVEDB,RELEASE_5_43_DRIVEDB,' update-smart-drivedb

Comment 6 Michal Hlavinka 2016-10-20 11:43:52 UTC
Hi Christian, thanks for your input, it's always appreciated. I have already prepared fix that uses backported update script as you've suggested.

Comment 7 Christian Franke 2016-10-20 12:42:48 UTC
You're welcome.  BTW, I'm working on a new script which improves security:
https://www.smartmontools.org/ticket/751
This script will also work with older releases.

Comment 11 errata-xmlrpc 2017-03-21 11:13:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0724.html


Note You need to log in before you can comment on or make changes to this bug.