Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367204 - Events lists no longer displays output of lifecycle hooks
Summary: Events lists no longer displays output of lifecycle hooks
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Andy Goldstein
QA Contact: DeShuai Ma
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-15 20:49 UTC by Matt Wringe
Modified: 2016-09-19 14:35 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-19 14:35:22 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC
Github kubernetes kubernetes pull 30731 None None None 2016-08-17 19:55:48 UTC
Origin (Github) 10494 None None None 2016-08-18 20:03:18 UTC

Description Matt Wringe 2016-08-15 20:49:10 UTC
Description of problem:

The events list used to list output from lifecycle hooks (eg readiness and lifecycle probes).

Without these messages from the lifecycle hooks it can be debugging certain situations very difficult. It also means we can't provide messages to users as to why the hook failed.

Comment 1 Michal Fojtik 2016-08-16 12:35:38 UTC
@mwringe are you referring to deployment hooks (pre/mid/post) and that they are not reporting errors to events OR you are referring to liveness and readiness probes not being reported in events?

Comment 2 Matt Wringe 2016-08-16 14:14:15 UTC
liveness and readiness probes, we used to get any output that these probes produced.

Comment 3 Andy Goldstein 2016-08-17 14:00:36 UTC
Please don't open bugs in both GitHub and here. Since you have this one, I'm going to close the GitHub issue (https://github.com/openshift/origin/issues/10424).

Upstream PR: https://github.com/kubernetes/kubernetes/pull/30731

Comment 4 Andy Goldstein 2016-08-17 14:01:35 UTC
This is specific to exec probes. There is a regression in Kube 1.3 that makes it so the output from exec probes is not included in the events.

Comment 5 DeShuai Ma 2016-08-23 06:44:28 UTC
Test on v3.3.0.24-dirty, "Readiness" event shows correctly
steps:
1. Create a pod with readiness exec probe
$ oc create -f https://raw.githubusercontent.com/mdshuai/testfile-openshift/master/k8s/readinessProbe-exec.yaml
2. Check event shows correctly.
[root@openshift-107 ~]# oc get event -n dma|grep "Readiness probe failed"
4s         4m          25        nginx     Pod       spec.containers{nginx}   Warning   Unhealthy   {kubelet openshift-159.lab.sjc.redhat.com}   Readiness probe failed: Get http://10.1.0.6:112/: dial tcp 10.1.0.6:112: getsockopt: connection refused

Comment 6 DeShuai Ma 2016-08-23 06:45:14 UTC
[root@openshift-107 ~]# oc get event -n dma|grep "Readiness probe"
7s         37s         4         hello-pod   Pod       spec.containers{hello-pod}   Warning   Unhealthy   {kubelet openshift-159.lab.sjc.redhat.com}   Readiness probe failed: exec: "/bin/hello": stat /bin/hello: no such file or directory


Note You need to log in before you can comment on or make changes to this bug.