Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367013 - firefox's Date.toLocaleString() doesn't consider daylight saving time's in its calculations
Summary: firefox's Date.toLocaleString() doesn't consider daylight saving time's in it...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-15 09:09 UTC by Hedayat Vatankhah
Modified: 2016-08-25 09:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-25 09:40:15 UTC


Attachments (Terms of Use)

Description Hedayat Vatankhah 2016-08-15 09:09:28 UTC
Description of problem:
Try http://browserspy.dk/date.php when your system timezone is set to a timezone which has DST now. You'll see that "Locale String" line has a different time from the system time (even if your locale is set to en_US). For example, this is what I see in my system: (timezone is fake)

Time and date 	Mon Aug 15 2016 16:31:39 GMT+0730 (XXDT)
GMT'ed 	Mon, 15 Aug 2016 09:01:39 GMT
Locale String 	8/15/2016, 15:31:39 PM
Time-Zone offset 	-450 minutes


Version-Release number of selected component (if applicable):
firefox-48.0-5.fc24.x86_64

How reproducible:
100%

Additional info:
It seems to be a Fedora specific bug. Tests on Ubuntu with same firefox version seems to be OK.

Comment 1 Jan Horak 2016-08-23 13:52:34 UTC
Are you able to reproduce it with upstream binaries (https://www.mozilla.org/en-US/firefox/new/?scene=2)?

I cannot reproduce it with CEST time zone (my zone has DST now):

Time and date 	Tue Aug 23 2016 15:47:04 GMT+0200 (CEST)
GMT'ed 	Tue, 23 Aug 2016 13:47:04 GMT
Locale String 	8/23/2016, 3:47:04 PM 

For further investigation I would need your exact timezone.

Comment 2 Hedayat Vatankhah 2016-08-23 18:58:50 UTC
I'll check upstream binaries & let you know. A timezone in which the problem can be reproduced is IRDT time zone.

Comment 3 Jan Horak 2016-08-25 09:40:15 UTC
Thanks for the feedback. Interesting, I've found the reproducer. We're going to  move it to the upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=1297984


Note You need to log in before you can comment on or make changes to this bug.