Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366990 - Import from Xen and KVM: import dilaog - VM should not be checked as "clone" when there is identical VM name in a different DC.
Summary: Import from Xen and KVM: import dilaog - VM should not be checked as "clone" ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.0.2.6
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ovirt-4.0.6
: ---
Assignee: Sharon Gratch
QA Contact: Nisim Simsolo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-15 08:17 UTC by Nisim Simsolo
Modified: 2016-11-02 13:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-02 13:51:27 UTC
oVirt Team: Virt
tjelinek: ovirt-4.0.z?
mgoldboi: planning_ack+
rule-engine: devel_ack?
mavital: testing_ack+


Attachments (Terms of Use)
vdsm.log (deleted)
2016-08-15 08:17 UTC, Nisim Simsolo
no flags Details
engine.log (deleted)
2016-08-15 08:19 UTC, Nisim Simsolo
no flags Details
first import dialog (deleted)
2016-08-15 08:20 UTC, Nisim Simsolo
no flags Details
second_import_dialog (deleted)
2016-08-15 08:21 UTC, Nisim Simsolo
no flags Details
VMware second import dialog (clone is unchecked) (deleted)
2016-08-15 08:23 UTC, Nisim Simsolo
no flags Details
KVM second import dialog (clone is checked) (deleted)
2016-08-15 08:23 UTC, Nisim Simsolo
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1303548 None None None Never

Internal Links: 1303548

Description Nisim Simsolo 2016-08-15 08:17:29 UTC
Description of problem:
- When selecting VM to import with an identical name to a VM which exists in different DC, the VM is set to clone in the second import dialog and cannot be imported not as a clone.
- This issue occurs also when importing from KVM environment.
- This Issue does not occur when importing from VMware environment.

Version-Release number of selected component (if applicable):
rhevm-4.0.2.6-0.1.el7ev
libvirt-client-1.2.17-13.el7_2.5.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.16.x86_64
vdsm-4.18.10-1.el7ev.x86_64
sanlock-3.2.4-2.el7_2.x86_64

How reproducible:
Consistently

Steps to Reproduce:
1. Browse webadmin -> Virtual machines tab -> import dialog, enter Xen details.
2. Select VM to import with a name that already exist in a different DC. 
3. move to next dialog.

Actual results:
VM is checked as clone although the identical VM name is in a different DC (see 
second_dialog.png screenshot attached) and VM cannot be imported not as a clone.

Expected results:
VM should not be checked as a clone in the second dialog page.

Additional info:
vdsm.log, engine.log and screenshots attached.

Comment 1 Nisim Simsolo 2016-08-15 08:17:55 UTC
Created attachment 1190809 [details]
vdsm.log

Comment 2 Nisim Simsolo 2016-08-15 08:19:05 UTC
Created attachment 1190810 [details]
engine.log

Comment 3 Nisim Simsolo 2016-08-15 08:20:37 UTC
Created attachment 1190811 [details]
first import dialog

Comment 4 Nisim Simsolo 2016-08-15 08:21:44 UTC
Created attachment 1190812 [details]
second_import_dialog

Comment 5 Nisim Simsolo 2016-08-15 08:23:00 UTC
Created attachment 1190813 [details]
VMware second import dialog (clone is unchecked)

Comment 6 Nisim Simsolo 2016-08-15 08:23:56 UTC
Created attachment 1190814 [details]
KVM second import dialog (clone is checked)

Comment 7 Sharon Gratch 2016-11-02 13:49:05 UTC
It is not a bug. Details:
A VM is marked as clone only if there is another vm in the system that has the SAME id, regardless to the data center it belongs to. The VM is is unique cross DCs.

So for XEN and KVM it work as expected in the attached tests because trying to import a VM that is already existed with the same id in the system (under other data center) should mark the VM as cloned.

For VMware it should work the same and it does. 

The reason it wasn't marked as clone in the attached test is that the existed VM had an id started with fb0f..... and the imported VM had an id started with 423c8...so those are 2 different VMS with the same name (see "VMware_second_dialog" attachment).

to summarize there are 2 scenarios:
1) import a VM with the same id as one existed in the system -> in this case the VM is marked to be imported as clone.

2) import a VM with the same name as other VM existed under a different dc, but with a different id -> in this case it will be imported as is (not marked as clone)


Note You need to log in before you can comment on or make changes to this bug.