Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366944 - Keystone v3 tempest tests are getting failed because of missing domain name.
Summary: Keystone v3 tempest tests are getting failed because of missing domain name.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tempest
Version: 8.0 (Liberty)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: 8.0 (Liberty)
Assignee: Martin Kopec
QA Contact: tkammer
URL:
Whiteboard:
: 1360755 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-15 06:03 UTC by VIKRANT
Modified: 2017-07-18 13:20 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-18 09:27:02 UTC


Attachments (Terms of Use)
rpm (deleted)
2017-01-09 08:29 UTC, Jaison Raju
no flags Details
opentack-redhat liberty branch (deleted)
2017-01-09 08:30 UTC, Jaison Raju
no flags Details

Description VIKRANT 2016-08-15 06:03:32 UTC
Description of problem:
Keystone v3 tempest tests are getting failed we are suspecting this is happening because of missing domain name.

Version-Release number of selected component (if applicable):
RHEL OSP 8 

How reproducible:
Everytime for Cu. 


Steps to Reproduce:
1. Run the tests located at "tempest/api/identity/admin/v3" on overcloud setup configured with keystone v3, tests are getting failed. 
3.

Actual results:
Keystone tempest tests are getting failed. 

Expected results:
Should get completed successfully. 

Additional info:

Similar sort of issue reported in Bug [1], but the Red Hat consultant found the workaround to make that test successful. Not able to determine the workaround for the rest of tests.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1360755

List of failed tests : 

~~~
$ testr failing --list
setUpClass (tempest.api.compute.floating_ips.test_list_floating_ips.FloatingIPDetailsTestJSON)
setUpClass (tempest.api.compute.floating_ips.test_floating_ips_actions.FloatingIPsTestJSON)
setUpClass (tempest.api.image.v1.test_images.ListImagesTest)
tempest.api.image.v1.test_images.CreateRegisterImagesTest.test_register_http_image[id-6d0e13a7-515b-460c-b91f-9f4793f09816]
setUpClass (tempest.api.compute.servers.test_server_rescue.ServerRescueTestJSON)
tempest.api.image.v1.test_images.CreateRegisterImagesTest.test_register_remote_image[id-69da74d9-68a9-404b-9664-ff7164ccb0f5]
tempest.api.compute.test_versions.TestVersions.test_get_version_details[id-b953a29e-929c-4a8e-81be-ec3a7e03cb76]
tempest.api.identity.admin.v3.test_inherits.InheritsV3TestJSON.test_inherit_assign_check_revoke_roles_on_projects_group[id-26021436-d5a4-4256-943c-ded01e0d4b45]
tempest.api.identity.admin.v3.test_inherits.InheritsV3TestJSON.test_inherit_assign_check_revoke_roles_on_projects_user[id-18b70e45-7687-4b72-8277-b8f1a47d7591]
tempest.api.identity.admin.v3.test_inherits.InheritsV3TestJSON.test_inherit_assign_list_check_revoke_roles_on_domains_group[id-c7a8dda2-be50-4fb4-9a9c-e830771078b1]
tempest.api.identity.admin.v3.test_inherits.InheritsV3TestJSON.test_inherit_assign_list_check_revoke_roles_on_domains_user[id-4e6f0366-97c8-423c-b2be-41eae6ac91c8]
tempest.api.identity.admin.v3.test_list_users.UsersV3TestJSON.test_list_users[id-b30d4651-a2ea-4666-8551-0c0e49692635]
tempest.api.identity.admin.v3.test_list_users.UsersV3TestJSON.test_list_users_with_name[id-c285bb37-7325-4c02-bff3-3da5d946d683]
tempest.api.identity.admin.v3.test_list_users.UsersV3TestJSON.test_list_users_with_not_enabled[id-bff8bf2f-9408-4ef5-b63a-753c8c2124eb]
tempest.api.identity.admin.v3.test_groups.GroupsV3TestJSON.test_list_groups[id-cc9a57a5-a9ed-4f2d-a29f-4f979a06ec71]
tempest.scenario.test_shelve_instance.TestShelveInstance.test_shelve_instance[compute,id-1164e700-0af0-4a4c-8792-35909a88743c,image,network]
tempest.scenario.test_snapshot_pattern.TestSnapshotPattern.test_snapshot_pattern[compute,id-608e604b-1d63-4a82-8e3e-91bc665c90b4,image,network]
tempest.scenario.test_network_v6.TestGettingAddress.test_dualnet_multi_prefix_dhcpv6_stateless[compute,id-cf1c4425-766b-45b8-be35-e2959728eb00,network]
tempest.scenario.test_network_v6.TestGettingAddress.test_dualnet_multi_prefix_slaac[compute,id-9178ad42-10e4-47e9-8987-e02b170cc5cd,network]
tempest.scenario.test_network_v6.TestGettingAddress.test_multi_prefix_slaac[compute,id-dec222b1-180c-4098-b8c5-cc1b8342d611,network,slow]
~~~


Results : 

~~~
======
Totals
======
Ran: 1157 tests in 2097.0000 sec.
 - Passed: 960
 - Skipped: 177
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 20
Sum of execute time for each test: 3893.3599 sec.

==============
Worker Balance
==============
 - Worker 0 (135 tests) => 0:10:21.399091
 - Worker 1 (168 tests) => 0:11:22.148822
 - Worker 2 (154 tests) => 0:16:52.331721
 - Worker 3 (165 tests) => 0:34:45.228747
 - Worker 4 (142 tests) => 0:06:25.260469
 - Worker 5 (139 tests) => 0:09:57.313421
 - Worker 6 (143 tests) => 0:09:59.095777
 - Worker 7 (111 tests) => 0:09:12.026118
~~~

Comment 4 Daniel Mellado 2016-10-14 13:13:38 UTC
*** Bug 1360755 has been marked as a duplicate of this bug. ***

Comment 5 Martin Kopec 2016-11-21 13:14:45 UTC
Can't reproduce it. It works for me.

Comment 8 Jaison Raju 2017-01-06 10:50:50 UTC
Hello Martin,

I tested on the following, but i still noticed the same errors .
openstack-tempest-liberty-20160413.1.el7ost.noarch

I am wondering if i did something wrong here .


$ testr failing --list
tempest.api.identity.admin.v3.test_inherits.InheritsV3TestJSON.test_inherit_assign_check_revoke_roles_on_projects_group[id-26021436-d5a4-4256-943c-ded01e0d4b45]
tempest.api.identity.admin.v3.test_inherits.InheritsV3TestJSON.test_inherit_assign_check_revoke_roles_on_projects_user[id-18b70e45-7687-4b72-8277-b8f1a47d7591]
tempest.api.identity.admin.v3.test_inherits.InheritsV3TestJSON.test_inherit_assign_list_check_revoke_roles_on_domains_group[id-c7a8dda2-be50-4fb4-9a9c-e830771078b1]
tempest.api.identity.admin.v3.test_inherits.InheritsV3TestJSON.test_inherit_assign_list_check_revoke_roles_on_domains_user[id-4e6f0366-97c8-423c-b2be-41eae6ac91c8]
tempest.api.identity.admin.v3.test_groups.GroupsV3TestJSON.test_list_groups[id-cc9a57a5-a9ed-4f2d-a29f-4f979a06ec71]
tempest.api.identity.admin.v3.test_list_users.UsersV3TestJSON.test_list_users[id-b30d4651-a2ea-4666-8551-0c0e49692635]
tempest.api.identity.admin.v3.test_list_users.UsersV3TestJSON.test_list_users_with_name[id-c285bb37-7325-4c02-bff3-3da5d946d683]
tempest.api.identity.admin.v3.test_list_users.UsersV3TestJSON.test_list_users_with_not_enabled[id-bff8bf2f-9408-4ef5-b63a-753c8c2124eb]
tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_get_trusts_all[id-4773ebd5-ecbf-4255-b8d8-b63e6f72b65d,smoke]
tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_get_trusts_query[id-6268b345-87ca-47c0-9ce3-37792b43403a]
tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_trust_expire[id-0ed14b66-cefd-4b5c-a964-65759453e292]
tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_trust_expire_invalid[id-3e48f95d-e660-4fa9-85e0-5a3d85594384]
tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_trust_impersonate[id-5a0a91a4-baef-4a14-baba-59bf4d7fcace]
tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_trust_noimpersonate[id-ed2a8779-a7ac-49dc-afd7-30f32f936ed2]

There are some V3 test succeeding also .
Here are some outputs:
http://pastebin.test.redhat.com/443584
PFA my test results .

Regards,
Jaison R

Comment 10 Jaison Raju 2017-01-09 08:29:46 UTC
Created attachment 1238582 [details]
rpm

Comment 11 Jaison Raju 2017-01-09 08:30:24 UTC
Created attachment 1238583 [details]
opentack-redhat liberty branch

Comment 12 Jaison Raju 2017-01-09 08:32:09 UTC
for opentack-redhat liberty branch , i also had to install couple of libraries in virtual env using pip .
Not sure if that could make a lot of difference in test .

Comment 13 Martin Kopec 2017-01-26 14:19:55 UTC
Please, try run tests not by rpm tempest but by tempest installed in virtual environment, for example according this documentation:

https://www.rdoproject.org/blog/2016/11/how-to-install-and-run-tempest/

Let me know, if the problem remains after that.

Comment 17 Jaison Raju 2017-04-24 13:25:55 UTC
Via rpm the same results are noticed .
[stack@instack tempest]$ testr failing --list
tempest.api.identity.admin.v3.test_inherits.InheritsV3TestJSON.test_inherit_assign_check_revoke_roles_on_projects_group[id-26021436-d5a4-4256-943c-ded01e0d4b45]
tempest.api.identity.admin.v3.test_inherits.InheritsV3TestJSON.test_inherit_assign_check_revoke_roles_on_projects_user[id-18b70e45-7687-4b72-8277-b8f1a47d7591]
tempest.api.identity.admin.v3.test_inherits.InheritsV3TestJSON.test_inherit_assign_list_check_revoke_roles_on_domains_group[id-c7a8dda2-be50-4fb4-9a9c-e830771078b1]
tempest.api.identity.admin.v3.test_inherits.InheritsV3TestJSON.test_inherit_assign_list_check_revoke_roles_on_domains_user[id-4e6f0366-97c8-423c-b2be-41eae6ac91c8]
tempest.api.identity.admin.v3.test_groups.GroupsV3TestJSON.test_list_groups[id-cc9a57a5-a9ed-4f2d-a29f-4f979a06ec71]
tempest.api.identity.admin.v3.test_list_users.UsersV3TestJSON.test_list_users[id-b30d4651-a2ea-4666-8551-0c0e49692635]
tempest.api.identity.admin.v3.test_list_users.UsersV3TestJSON.test_list_users_with_name[id-c285bb37-7325-4c02-bff3-3da5d946d683]
tempest.api.identity.admin.v3.test_list_users.UsersV3TestJSON.test_list_users_with_not_enabled[id-bff8bf2f-9408-4ef5-b63a-753c8c2124eb]
tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_get_trusts_all[id-4773ebd5-ecbf-4255-b8d8-b63e6f72b65d,smoke]
tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_get_trusts_query[id-6268b345-87ca-47c0-9ce3-37792b43403a]
tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_trust_expire[id-0ed14b66-cefd-4b5c-a964-65759453e292]
tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_trust_expire_invalid[id-3e48f95d-e660-4fa9-85e0-5a3d85594384]
tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_trust_impersonate[id-5a0a91a4-baef-4a14-baba-59bf4d7fcace]
tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_trust_noimpersonate[id-ed2a8779-a7ac-49dc-afd7-30f32f936ed2]
PFA: ~/tempest/.testrepository/1


Via rdo liberty git , the same failures are seen . Except that here 'test_inherits' test cases are skipped . But if i include them , those failures are seen too .
(.venv)[stack@instack tempest]$ testr failing --list 
tempest.api.identity.admin.v3.test_groups.GroupsV3TestJSON.test_list_groups[id-cc9a57a5-a9ed-4f2d-a29f-4f979a06ec71]
tempest.api.identity.admin.v3.test_inherits.InheritsV3TestJSON.test_inherit_assign_check_revoke_roles_on_projects_group[id-26021436-d5a4-4256-943c-ded01e0d4b45]
tempest.api.identity.admin.v3.test_inherits.InheritsV3TestJSON.test_inherit_assign_check_revoke_roles_on_projects_user[id-18b70e45-7687-4b72-8277-b8f1a47d7591]
tempest.api.identity.admin.v3.test_inherits.InheritsV3TestJSON.test_inherit_assign_list_check_revoke_roles_on_domains_group[id-c7a8dda2-be50-4fb4-9a9c-e830771078b1]
tempest.api.identity.admin.v3.test_inherits.InheritsV3TestJSON.test_inherit_assign_list_check_revoke_roles_on_domains_user[id-4e6f0366-97c8-423c-b2be-41eae6ac91c8]
tempest.api.identity.admin.v3.test_list_users.UsersV3TestJSON.test_list_users[id-b30d4651-a2ea-4666-8551-0c0e49692635]
tempest.api.identity.admin.v3.test_list_users.UsersV3TestJSON.test_list_users_with_name[id-c285bb37-7325-4c02-bff3-3da5d946d683]
tempest.api.identity.admin.v3.test_list_users.UsersV3TestJSON.test_list_users_with_not_enabled[id-bff8bf2f-9408-4ef5-b63a-753c8c2124eb]
tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_get_trusts_all[id-4773ebd5-ecbf-4255-b8d8-b63e6f72b65d,smoke]
tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_get_trusts_query[id-6268b345-87ca-47c0-9ce3-37792b43403a]
tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_trust_expire[id-0ed14b66-cefd-4b5c-a964-65759453e292]
tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_trust_expire_invalid[id-3e48f95d-e660-4fa9-85e0-5a3d85594384]
tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_trust_impersonate[id-5a0a91a4-baef-4a14-baba-59bf4d7fcace]
tempest.api.identity.admin.v3.test_trusts.TrustsV3TestJSON.test_trust_noimpersonate[id-ed2a8779-a7ac-49dc-afd7-30f32f936ed2]



PFA: 
With default tempest.conf : ~/rdo_tempest/tempest/.testrepository/0
With 'api_extension = all' for identity-feature-enabled : ~/rdo_tempest/tempest/.testrepository/1

Martin , did you test keystone which is already configured with a backend like IPA ?
https://access.redhat.com/documentation/en/red-hat-openstack-platform/version-8/integrate-with-identity-service/#configure_the_idm_server

I will mail you the KVM Host details where i have configured keystone backed by IPA &  collected these outputs .

Regards,
Jaison R

Comment 19 Martin Magr 2017-07-18 09:27:02 UTC
Closing this bug as the problem could not be reproduced and automation tests did not discover any problem also. Unless there is a 100% reproducer I'm afraid we cannot help there.


Note You need to log in before you can comment on or make changes to this bug.