Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366942 - [WALA] Some parameters are redundant in waagent.conf
Summary: [WALA] Some parameters are redundant in waagent.conf
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: WALinuxAgent
Version: 7.3
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: yuxisun@redhat.com
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-15 05:55 UTC by yuxisun@redhat.com
Modified: 2019-02-26 20:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 08:30:57 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github Azure WALinuxAgent issues 360 None None None 2016-08-15 05:55:04 UTC

Description yuxisun@redhat.com 2016-08-15 05:55:05 UTC
Description of problem:
The "Role.ConfigurationConsumer" and "Role.TopologyConsumer" parameters in waagent.conf are useless for WALA. Need to be removed.

Version-Release number of selected component (if applicable):
WALinuxAgent-2.1.5 (upstream, package by tester)

RHEL Version:
RHEL-7.3-20160729.1

How reproducible:
100%

Steps to Reproduce:
1. Prepare a 7.3 VM on Azure.
2. Check the parameters in /etc/waagent.conf
# vi /etc/waagent.conf

Actual results:
Such parameters are inside the waagent.conf, which are useless in WALA:

# Specified program is invoked with XML file argument specifying role
#  configuration.
Role.ConfigurationConsumer=None

# Specified program is invoked with XML file argument specifying role topology.
Role.TopologyConsumer=None

Expected results:
There's no useless parameters in waagent.conf.

Additional info:
There's no functions in azurelinuxagent/common/conf.py to get these parameters.

Comment 2 yuxisun@redhat.com 2016-10-27 07:30:50 UTC
Verify in WALA-2.2.0 RHEL-7.3-20161019.0

These parameters are removed from /etc/waagent.conf:

Role.ConfigurationConsumer
Role.TopologyConsumer
Role.StateConsumer

Comment 3 yuxisun@redhat.com 2016-11-04 08:30:57 UTC

*** This bug has been marked as a duplicate of bug 1387783 ***


Note You need to log in before you can comment on or make changes to this bug.