Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366937 - 'NoneType' object does not support item assignment
Summary: 'NoneType' object does not support item assignment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: atomic
Version: 7.4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Brent Baude
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-15 03:24 UTC by Alex Jia
Modified: 2016-11-04 09:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Atomic scan of a non existing image, throws an error of NoneType. This fix will show a proper message that the image does not exist.
Clone Of:
Environment:
Last Closed: 2016-11-04 09:06:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2628 normal SHIPPED_LIVE atomic bug fix and enhancement update 2016-11-03 18:17:14 UTC

Description Alex Jia 2016-08-15 03:24:18 UTC
Description of problem:
the atomic scanner doesn't work if the image does not exist on the local, and got error like this "'NoneType' object does not support item assignmentn".

Version-Release number of selected component (if applicable):
[cloud-user@atomic-00 ~]$ cat /etc/redhat-release 
Red Hat Enterprise Linux Atomic Host release 7.2
[cloud-user@atomic-00 ~]$ sudo atomic host status
State: idle
Deployments:
● rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard
       Version: 7.2.6 (2016-07-29 19:54:25)
        Commit: b672bf8a457cb28e003dee20c53749636ef5fce3e4743afe4aaad269d3aaa62a
        OSName: rhel-atomic-host
  GPGSignature: 1 signature
                Signature made Fri 29 Jul 2016 07:54:50 PM UTC using RSA key ID 199E2F91FD431D51
                Good signature from "Red Hat, Inc. <security@redhat.com>"
[cloud-user@atomic-00 ~]$ rpm -q atomic docker
atomic-1.10.5-7.el7.x86_64
docker-1.10.3-46.el7.10.x86_64

How reproducible:
always

Steps to Reproduce:

1. make sure registry.access.redhat.com/rhel7 doesn't exist on the local host
2. sudo atomic scan --scanner openscap --scan_type cve registry.access.redhat.com/rhel7


Actual results:
[cloud-user@atomic-00 ~]$ sudo atomic scan --scanner openscap --scan_type cve registry.access.redhat.com/rhel7
'NoneType' object does not support item assignmentn

Expected results:
Raise a friendly error message or try to help user to download target image.

Additional info:

In addition, in error message, it seems a typo exists, s/assignmentn/assignment/.

Comment 2 Micah Abbott 2016-08-15 13:28:40 UTC
This looks like it is fixed in the master branch upstream:

# git rev-parse HEAD
42c6094e3fd2f69fcfb34f0cc19bae89e226a7bd
# docker images | grep rhel6
# ./atomic scan --list
Scanner: atomic_scan_openscap 
  Image Name: docker.io/fedora/atomic_scan_openscap
     Scan type: cve * 
     Description: Performs a CVE scan based on known CVE data


* denotes defaults
# ./atomic scan registry.access.redhat.com/rhel6
Unable to associate 'registry.access.redhat.com/rhel6' with an image or container

Comment 3 Daniel Walsh 2016-08-26 16:08:41 UTC
With atomic-1.12.0-devel I am seeing the following.

# atomic scan --scanner openscap --scan_type cve registry.access.redhat.com/rhel7
Unable to associate 'registry.access.redhat.com/rhel7' with an image or container

Fixed in atomic-1.12

Comment 5 Alex Jia 2016-09-18 06:08:25 UTC
Moving to VERIFIED status per Comment 3 and following testing.

# rpm -q atomic
atomic-1.12.0-1.el7.x86_64

# atomic scan --scanner openscap --scan_type cve registry.access.redhat.com/rhel6
Unable to associate 'registry.access.redhat.com/rhel6' with an image or container

Comment 7 errata-xmlrpc 2016-11-04 09:06:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2628.html


Note You need to log in before you can comment on or make changes to this bug.