Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366894 - Chromium breaks when built against glibc 2.24 (2.23.90) which defines MADV_FREE
Summary: Chromium breaks when built against glibc 2.24 (2.23.90) which defines MADV_FREE
Keywords:
Status: CLOSED DUPLICATE of bug 1361157
Alias: None
Product: Fedora
Classification: Fedora
Component: chromium
Version: 25
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL: https://www.mail-archive.com/openembe...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-14 10:14 UTC by Kevin Kofler
Modified: 2016-08-15 17:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-15 17:10:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1364781 None None None Never

Internal Links: 1364781

Description Kevin Kofler 2016-08-14 10:14:13 UTC
Description of problem:
Chromium crashes in Fedora 25 and Rawhide with a backtrace such as:
Received signal 4 ILL_ILLOPN 7f58262eac90
#0 0x7f58266a864e <unknown>
…
(Ignore the addresses above, those are actually from QtWebEngine, I don't have a Chromium backtrace saved right now.)

This happens because the packages there are built at compile time against glibc 2.25, which defines the MADV_FREE macro. So the memory allocation code in "WTF" (a part of WebKit/Blink) tries to use that instead of MADV_DONTNEED, but the sandbox only allows MADV_DONTNEED.

QtWebEngine upstream now carries this fix:
http://code.qt.io/cgit/qt/qtwebengine-chromium.git/commit/?h=49-based&id=b12ffcd411d4776f7120ccecb3be34344d930d2b
(which is misleadingly/incompletely labeled in the commit message – even if you have a new enough kernel, as we do, MADV_FREE is not going to work because the sandbox does not allow it). I backported that to my QtWebEngine packaging. But, since Chromium crashes with the same backtrace, it also needs some version of this fix. (Unfortunately, the Qt patch is only in 49-based so far, not in one of the branches based on a newer Chromium.)

Version-Release number of selected component (if applicable):
chromium-52.0.2743.116-1.fc25
chromium-52.0.2743.116-1.fc26

How reproducible:
Always

Steps to Reproduce:
1. Boot a F25/Rawhide Live image.
2. dnf install chromium
3. sudo setenforce 0 to work around bug #1363914
4. sudo chmod a+w /dev/shm to work around bug #1347436
5. Try starting chromium.

Actual results:
Received signal 4 ILL_ILLOPN

Expected results:
No crash.

Additional info:
The OpenEmbedded report of Chromium no longer working when built against glibc 2.24:
https://www.mail-archive.com/openembedded-core@lists.openembedded.org/msg82915.html

The QtWebEngine Fedora bug where I debugged that (with the help of Florian Weimer) to find all the details I am providing in this bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1364781

Comment 1 Kevin Kofler 2016-08-14 21:26:50 UTC
And to be clear, yes, we have tested the Fedora chromium package and it crashed in the way described above, which is why I filed this bug.

Comment 2 Tom "spot" Callaway 2016-08-15 17:10:23 UTC

*** This bug has been marked as a duplicate of bug 1361157 ***


Note You need to log in before you can comment on or make changes to this bug.