Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366893 - [RFE] Container Image Scan doesn't stop when Smart Scan is set to Off
Summary: [RFE] Container Image Scan doesn't stop when Smart Scan is set to Off
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: GA
: cfme-future
Assignee: John Hardy
QA Contact: Pavel Zagalsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-14 10:08 UTC by Pavel Zagalsky
Modified: 2018-01-02 12:20 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-02 12:20:21 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pavel Zagalsky 2016-08-14 10:08:10 UTC
Description of problem:

Container Image Scan doesn't stop when Smart Scan is set to Off

Version-Release number of selected component (if applicable):
5.6.1.2.20160810181333_8ba817b

How reproducible:
Always

Steps to Reproduce:
1. Go to Settings --> Configuration and turn off the SmartState Analysis  option
2. Go to Compute --> Containers --> Container Images
3. Select an image and press on Configuration --> Perform SmartState Analysis 
4. Go to Settings --> Tasks --> All VM and Container Analysis Tasks
5. Check the status of the task that was just run

Actual results:
The task starts and doesn't stop until the Smart Scan is turned on

Expected results:
There should be some mechanism to prevent the user from running Smart Scan if this option is turned off.
This task should not have been started at all

Additional info:
Log attached here
http://pastebin.test.redhat.com/402332

Comment 5 Einat Pacifici 2018-01-02 12:20:21 UTC
Closing due to age of BZ. Currently if set to "off" the menu item is grayed out.


Note You need to log in before you can comment on or make changes to this bug.