Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366857 - current dnsyo program requires unavailable dnspython-1.11.1, but package doesn't
Summary: current dnsyo program requires unavailable dnspython-1.11.1, but package doesn't
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnsyo
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Rick Elrod
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1307428
TreeView+ depends on / blocked
 
Reported: 2016-08-13 14:48 UTC by J. Randall Owens
Modified: 2017-05-22 07:02 UTC (History)
1 user (show)

Fixed In Version: dnsyo-2.0.7-2.fc24 dnsyo-2.0.7-2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-22 06:51:09 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1307428 None None None Never

Internal Links: 1307428

Description J. Randall Owens 2016-08-13 14:48:54 UTC
Description of problem:
Currently, on an up-to-date Fedora 24, dnsyo crashes immediately.

Version-Release number of selected component (if applicable):
dnsyo-1.1.4-4.fc21.noarch (well, fc21 might explain a bit)

How reproducible:
every time

Steps to Reproduce:
1. install dnsyo
2. `dnsyo foo.com` or `dnsyo --help`

Actual results:
Traceback . . .
pkg_resources.DistributionNotFound: The 'dnspython==1.11.1' distribution was not found and is required by dnsyo
Exit 1

Expected results:
Not sure, I've never tried it before, but not this.

Additional info:
I'm assuming dnspython is what's provided by the python2-dns & python3-dns packages, which are currently at 1.12.0GITa477433-1.fc24. dnsyo the package currently just Requires an unversioned python-dns, but apparently the program itself feels rather strongly otherwise, and currently wants the old 1.11.1.

Comment 1 J. Randall Owens 2016-08-13 14:57:05 UTC
It looks like this might also explain the FTBFS #1307428. It looks like the build uses something called help2man, which I'm guessing converts the --help output into a man page. But as I noted above, even --help fails, so that fails during the build, bringing it to a stop. Fix this, and I bet it builds again. (Not much else that can go wrong with a typical noarch package.)

Comment 2 Fedora Update System 2016-08-17 00:57:31 UTC
dnsyo-2.0.7-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-0c5ca3f13a

Comment 3 Fedora Update System 2016-08-17 00:57:40 UTC
dnsyo-2.0.7-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-55774fa3ac

Comment 4 Fedora Update System 2016-08-17 00:57:47 UTC
dnsyo-2.0.7-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1a4cb9c780

Comment 5 Fedora Update System 2016-08-17 00:57:53 UTC
dnsyo-2.0.7-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-e8bb5db00f

Comment 6 Fedora Update System 2016-08-17 00:57:59 UTC
dnsyo-2.0.7-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ef40c656f5

Comment 7 Fedora Update System 2016-08-17 19:53:51 UTC
dnsyo-2.0.7-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1a4cb9c780

Comment 8 Fedora Update System 2016-08-18 01:51:24 UTC
dnsyo-2.0.7-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ef40c656f5

Comment 9 Fedora Update System 2016-08-18 01:52:07 UTC
dnsyo-2.0.7-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-55774fa3ac

Comment 10 Fedora Update System 2016-08-18 04:19:03 UTC
dnsyo-2.0.7-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-e8bb5db00f

Comment 11 Fedora Update System 2016-08-18 04:19:15 UTC
dnsyo-2.0.7-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-0c5ca3f13a

Comment 12 J. Randall Owens 2016-11-20 13:13:30 UTC
Now it's the same, except python3-dns has been updated to 1.15.0 in the meantime, and dnsyo is demanding 1.12.0, so it still fails & tracebacks. Going to have to try again. (Sorry I took so long to test, I was moving overseas, just finally got the real computer set up here.)

Comment 13 J. Randall Owens 2016-12-18 17:15:55 UTC
Problem persists in FC25, since it still has the 1.1.4-4.fc21 version in the release repo, and essentially the same 2.0.7-1.fc25 in updates-testing. (My above comment#12 was referring to 2.0.7-1.fc24 in updates-testing, I should have specified.)

Comment 14 Fedora Update System 2017-01-03 02:15:07 UTC
dnsyo-2.0.7-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-2d085a8365

Comment 15 Fedora Update System 2017-01-03 02:15:42 UTC
dnsyo-2.0.7-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-81ef82396e

Comment 16 Fedora Update System 2017-01-03 22:20:50 UTC
dnsyo-2.0.7-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-81ef82396e

Comment 17 Fedora Update System 2017-01-03 23:50:25 UTC
dnsyo-2.0.7-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-2d085a8365

Comment 18 Fedora Update System 2017-05-22 06:51:09 UTC
dnsyo-2.0.7-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2017-05-22 07:02:13 UTC
dnsyo-2.0.7-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.