Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366852 - SELinux is preventing fprintd from 'wake_alarm' accesses on the capability2 Unknown.
Summary: SELinux is preventing fprintd from 'wake_alarm' accesses on the capability2 U...
Keywords:
Status: CLOSED DUPLICATE of bug 1361616
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f61a6e778063647f6d62ad36f8f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-13 13:36 UTC by Jared Smith
Modified: 2016-08-16 16:06 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-16 16:06:29 UTC


Attachments (Terms of Use)

Description Jared Smith 2016-08-13 13:36:27 UTC
Description of problem:
Tried to do a "dnf update" and got lots of these SELinux alerts.
SELinux is preventing fprintd from 'wake_alarm' accesses on the capability2 Unknown.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that fprintd should be allowed wake_alarm access on the Unknown capability2 by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'fprintd' --raw | audit2allow -M my-fprintd
# semodule -X 300 -i my-fprintd.pp

Additional Information:
Source Context                system_u:system_r:fprintd_t:s0
Target Context                system_u:system_r:fprintd_t:s0
Target Objects                Unknown [ capability2 ]
Source                        fprintd
Source Path                   fprintd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-207.fc26.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.8.0-0.rc0.git3.1.fc26.x86_64 #1
                              SMP Fri Jul 29 15:09:32 UTC 2016 x86_64 x86_64
Alert Count                   5749
First Seen                    2016-08-06 02:03:27 EDT
Last Seen                     2016-08-13 09:34:54 EDT
Local ID                      a6aa6dec-5d8b-4398-9dd0-aa5de4415e43

Raw Audit Messages
type=AVC msg=audit(1471095294.751:993): avc:  denied  { wake_alarm } for  pid=28070 comm="fprintd" capability=35  scontext=system_u:system_r:fprintd_t:s0 tcontext=system_u:system_r:fprintd_t:s0 tclass=capability2 permissive=0


Hash: fprintd,fprintd_t,fprintd_t,capability2,wake_alarm

Version-Release number of selected component:
selinux-policy-3.13.1-207.fc26.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.8.0-0.rc0.git3.1.fc26.x86_64
type:           libreport

Potential duplicate: bug 1361616

Comment 1 Lukas Vrabec 2016-08-16 16:06:29 UTC

*** This bug has been marked as a duplicate of bug 1361616 ***


Note You need to log in before you can comment on or make changes to this bug.