Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366815 - spurious heal info as pending heal entries never end on an EC volume while IOs are going on
Summary: spurious heal info as pending heal entries never end on an EC volume while IO...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Ashish Pandey
QA Contact:
URL:
Whiteboard:
Depends On: 1347257
Blocks: 1383913
TreeView+ depends on / blocked
 
Reported: 2016-08-13 01:29 UTC by Pranith Kumar K
Modified: 2017-03-06 17:22 UTC (History)
10 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1347257
: 1383913 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:22:10 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2016-09-22 08:10:42 UTC
REVIEW: http://review.gluster.org/15543 (cluster/ec: Implement heal info with lock) posted (#3) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 2 Worker Ant 2016-09-26 08:28:29 UTC
REVIEW: http://review.gluster.org/15543 (cluster/ec: Implement heal info with lock) posted (#4) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 3 Worker Ant 2016-09-26 08:37:08 UTC
REVIEW: http://review.gluster.org/15543 (cluster/ec: Implement heal info with lock) posted (#5) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 4 Worker Ant 2016-09-28 07:37:29 UTC
REVIEW: http://review.gluster.org/15543 (cluster/ec: Implement heal info with lock) posted (#6) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 5 Worker Ant 2016-09-28 11:18:19 UTC
REVIEW: http://review.gluster.org/15543 (cluster/ec: Implement heal info with lock) posted (#7) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 6 Worker Ant 2016-09-28 18:35:44 UTC
REVIEW: http://review.gluster.org/15543 (cluster/ec: Implement heal info with lock) posted (#8) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 7 Worker Ant 2016-09-29 12:01:01 UTC
REVIEW: http://review.gluster.org/15543 (cluster/ec: Implement heal info with lock) posted (#9) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 8 Worker Ant 2016-09-29 12:04:44 UTC
REVIEW: http://review.gluster.org/15543 (cluster/ec: Implement heal info with lock) posted (#10) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 9 Worker Ant 2016-09-29 15:59:08 UTC
REVIEW: http://review.gluster.org/15543 (cluster/ec: Implement heal info with lock) posted (#11) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 10 Worker Ant 2016-10-03 07:20:32 UTC
REVIEW: http://review.gluster.org/15543 (cluster/ec: Implement heal info with lock) posted (#12) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 11 Worker Ant 2016-10-04 05:52:12 UTC
REVIEW: http://review.gluster.org/15543 (cluster/ec: Implement heal info with lock) posted (#13) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 12 Worker Ant 2016-10-04 07:39:53 UTC
REVIEW: http://review.gluster.org/15543 (cluster/ec: Implement heal info with lock) posted (#14) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 13 Worker Ant 2016-10-11 09:29:31 UTC
COMMIT: http://review.gluster.org/15543 committed in master by Xavier Hernandez (xhernandez@datalab.es) 
------
commit 0fed7e7f0aad9973900c89434f736797d9ace2bd
Author: Ashish Pandey <aspandey@redhat.com>
Date:   Tue Sep 20 12:32:28 2016 +0530

    cluster/ec: Implement heal info with lock
    
    Problem: Currently heal info command prints all
    the files/directories if the index for the
    file/directory is present in .glusterfs/indices folder.
    After implementing patch http://review.gluster.org/#/c/13733/
    indices of the file which is going through update fop
    will also be present in .glusterfs/indices even
    if the fop is successful on all the brick. At this time
    if heal info command is being used, it will also display this
    file which is actually healthy and does not require any heal.
    
    Solution: Take lock on a file corresponding to the indices
    and inspect xattrs to decide if the file needs heal or not.
    
    Change-Id: I6361e2813ece369be12d02e74816df4eddb81cfa
    BUG: 1366815
    Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    Reviewed-on: http://review.gluster.org/15543
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>

Comment 14 Shyamsundar 2017-03-06 17:22:10 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.