Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366802 - [extras-rhel-7.3.0] docker-containerd left running after rpm -e docker-*
Summary: [extras-rhel-7.3.0] docker-containerd left running after rpm -e docker-*
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker-latest
Version: 7.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Lokesh Mandvekar
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1366803
TreeView+ depends on / blocked
 
Reported: 2016-08-12 21:19 UTC by Qian Cai
Modified: 2017-08-02 00:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1366803 (view as bug list)
Environment:
Last Closed: 2017-08-02 00:14:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2345 normal SHIPPED_LIVE docker-latest bug fix and enhancement update 2017-08-08 22:51:48 UTC

Description Qian Cai 2016-08-12 21:19:21 UTC
Description of problem:
# rpm -qa | grep docker | xargs rpm -e
warning: /etc/sysconfig/docker-latest-storage-setup saved as /etc/sysconfig/docker-latest-storage-setup.rpmsave
warning: /etc/sysconfig/docker-latest-storage saved as /etc/sysconfig/docker-latest-storage.rpmsave

# # ps aux | grep docker
root      9865  0.0  0.1  45496  6156 ?        Ssl  Aug11   0:09 /usr/libexec/docker/rhel-push-plugin
root     14948  0.0  0.1 277012  6804 ?        Ssl  17:11   0:00 /usr/libexec/docker/docker-containerd --listen /run/containerd.sock --runtime /usr/libexec/docker/docker-runc --runtime-args --systemd-cgroup=true
root     15358  0.0  0.0 112648   976 pts/2    R+   17:14   0:00 grep --color=auto docker

I'll fill another bug for rhel-push-plugin.

Version-Release number of selected component (if applicable):
# rpm -qa | grep docker
docker-common-1.10.3-46.el7.10.x86_64
docker-rhel-push-plugin-1.10.3-46.el7.10.x86_64
docker-selinux-1.10.3-46.el7.10.x86_64
docker-latest-1.12.0-4.el7.x86_64

How reproducible:
always

Comment 2 Lokesh Mandvekar 2016-08-17 18:29:58 UTC
This also seems best handled with the plugin packages inside docker. I'll schedule it for 7.3.0 unless you think it should be handled earlier.

Comment 3 Daniel Walsh 2016-08-19 21:22:44 UTC
Can we move this to the modified state?

Comment 6 Qian Cai 2017-01-26 14:41:26 UTC
What's the status of this BZ?

Comment 7 Frantisek Kluknavsky 2017-07-12 14:03:10 UTC
With docker-1.12.6-34.gitf55a118.el7.x86_64 (latest 7.3 currently):

# ps axu|grep docker
root      1677  0.0  0.4  31228  4700 ?        Ssl  08:58   0:00 /usr/libexec/docker/rhel-push-plugin
root      1699  0.8  2.1 563024 22240 ?        Ssl  08:58   0:00 /usr/bin/dockerd-current --add-runtime docker-runc=/usr/libexec/docker/docker-runc-current --default-runtime=docker-runc --authorization-plugin=rhel-push-plugin --exec-opt native.cgroupdriver=systemd --userland-proxy-path=/usr/libexec/docker/docker-proxy-current --selinux-enabled --log-driver=journald --signature-verification=false --add-registry registry.access.redhat.com
root      1704  0.0  0.6 262972  6924 ?        Ssl  08:58   0:00 /usr/bin/docker-containerd-current -l unix:///var/run/docker/libcontainerd/docker-containerd.sock --shim docker-containerd-shim --metrics-interval=0 --start-timeout 2m --state-dir /var/run/docker/libcontainerd/containerd --runtime docker-runc --runtime-args --systemd-cgroup=true
root      1808  0.0  0.0 112660   992 pts/0    R+   08:58   0:00 grep --color=auto docker

# rpm -qa|grep docker|xargs yum erase

# ps axu|grep docker
root      1944  0.0  0.0 112660   992 pts/0    S+   09:02   0:00 grep --color=auto docker

Seems working correctly

Comment 9 Luwen Su 2017-07-24 09:37:49 UTC
Works fine in docker-latest-1.13.1-21.1.gitcd75c68.el7.x86_64.rpm, move to verified.

Comment 11 errata-xmlrpc 2017-08-02 00:14:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2345


Note You need to log in before you can comment on or make changes to this bug.