Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366691 - [RFE] katello-service status output is very difficult to overview
Summary: [RFE] katello-service status output is very difficult to overview
Keywords:
Status: CLOSED DUPLICATE of bug 1397555
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Infrastructure
Version: 6.2.0
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: jcallaha
URL:
Whiteboard:
: 1492585 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-12 15:19 UTC by Magnus Glantz
Modified: 2018-07-18 12:32 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-18 12:32:47 UTC


Attachments (Terms of Use)
Suggested patch to limit output (deleted)
2016-08-12 15:19 UTC, Magnus Glantz
no flags Details | Diff

Description Magnus Glantz 2016-08-12 15:19:16 UTC
Created attachment 1190465 [details]
Suggested patch to limit output

Description of problem:
katello-service status output is very difficult to overview. When you run katello-service status you want a brief overview of the solutions status, not the full systemctl status output.

Version-Release number of selected component (if applicable):
Satellite 6.2.0
katello-service-2.2.0.19-1.el7sat.noarch
katello-common-2.2.0.19-1.el7sat.noarch

How reproducible:
katello-service status

Steps to Reproduce:
1. Run katello-service status
2. Observe that it's output is over 182 lines.

Actual results:
Status output is over 182 lines. Impossible to overview.

Expected results:
Just information about what services and what state it has, not the full systemctl status output.

Additional info:
With my patch output is displayed as follows:

[root@sat6 ~]# /usr/bin/katello-service.new status
Status for: mongod
   Active: active (running) since Fri 2016-08-12 14:37:06 CEST; 2h 39min ago
Status for: qpidd
   Active: active (running) since Fri 2016-08-12 16:45:06 CEST; 31min ago
Status for: qdrouterd
   Active: active (running) since Fri 2016-08-12 14:37:11 CEST; 2h 39min ago
Status for: tomcat
   Active: active (running) since Fri 2016-08-12 14:37:12 CEST; 2h 39min ago
Status for: elasticsearch
   Active: active (running) since Fri 2016-08-12 14:37:12 CEST; 2h 39min ago
Status for: foreman-proxy
   Active: active (running) since Fri 2016-08-12 14:37:30 CEST; 2h 39min ago
Status for: pulp_celerybeat
   Active: active (running) since Fri 2016-08-12 16:47:49 CEST; 28min ago
Status for: pulp_resource_manager
   Active: active (running) since Fri 2016-08-12 14:37:32 CEST; 2h 38min ago
Status for: pulp_workers
   Active: active (exited) since Fri 2016-08-12 14:37:33 CEST; 2h 38min ago
Status for: httpd
   Active: active (running) since Fri 2016-08-12 14:37:35 CEST; 2h 38min ago
Status for: foreman-tasks
   Active: active (running) since Fri 2016-08-12 14:39:17 CEST; 2h 37min ago
Success!

Comment 2 Brad Buckingham 2017-09-20 19:20:04 UTC
*** Bug 1492585 has been marked as a duplicate of this bug. ***

Comment 3 Brad Buckingham 2017-09-20 19:20:42 UTC
*** Bug 1450438 has been marked as a duplicate of this bug. ***

Comment 4 Brad Buckingham 2017-09-20 19:21:57 UTC
When implementing the solution to this bugzilla, please refer to attached duplicates (e.g. Blocks) for additional input on possible solutions.

Comment 5 sthirugn@redhat.com 2018-07-18 12:32:47 UTC

*** This bug has been marked as a duplicate of bug 1397555 ***


Note You need to log in before you can comment on or make changes to this bug.