Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366645 - OpenSSL libraries are not linked correctly
Summary: OpenSSL libraries are not linked correctly
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: RPMs, openssl
Version: 6.4.9
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: CR2
: EAP 6.4.9
Assignee: Fernando Nasser
QA Contact: Ivo Hradek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-12 13:59 UTC by Ivo Hradek
Modified: 2017-01-17 14:46 UTC (History)
5 users (show)

Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-17 14:46:23 UTC
Type: Bug


Attachments (Terms of Use)

Description Ivo Hradek 2016-08-12 13:59:28 UTC
Description of problem:
EAP was installed from rpm with natives. For some operating system EAP is still using openssl loaded from the system instead of EAP rpm's libraries as it was expected.

The problem is because of bad linked libs in web module.

Issue appears on the following systems:
 - RHEL5 (i386, x86_64)
 - RHEL6 (i386, x86_64, ppc64)
 - RHEL7 (ppc64)

Note: For RHEL7x86_64 it seems that links are correct.

Steps to Reproduce:
1. ls -l $JBOSS_HOME/modules/system/layers/base/org/jboss/as/web/main/lib/*
2. Check the sym-links for (libssl, libcrypto)

Actual results:
System's OpenSSL is used.

Expected results:
OpenSSL from EAP rpm's should be used.

Please consider if LD_LIBRARY_PATH should be not set during EAP rpm installation.

Comment 1 Michal Karm Babacek 2016-08-17 12:38:42 UTC
There is no RHEL5 build of OpenSSL 1.0.2h, please ignore the platform Ivo.

Comment 2 Permaine Cheung 2016-08-22 13:15:04 UTC
Coty has done new builds of tomcat-native, and the links seem to be pointing to the correct locations:

tomcat-native-1.1.34-5.redhat_1.ep6.el[67]
https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=508794
https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=508797

Can you please check the jbossas-jbossweb-native subpackage of the above builds before I flip the errata back to QE? Thanks!

Comment 3 Ivo Hradek 2016-08-22 14:37:47 UTC
I've checked it. Indeed, all symlinks have been corrected with new builds, so all are pointing to the right locations now.

Thanks.
--
Just for a record: It seems that only tomcat-native-1.1.34-3.redhat_1.ep6.el[6/7] builds were affected.

Comment 4 Permaine Cheung 2016-08-22 19:12:58 UTC
Thanks Ivo!
The new builds are in the errata which are in QE state, changing this to ON_QA.

Comment 5 Ivo Hradek 2016-09-22 06:40:42 UTC
Verified, issue was fixed.

Comment 6 Petr Penicka 2017-01-17 14:46:23 UTC
Retroactively bulk-closing issues from released EAP 6.4 cumulative patches.


Note You need to log in before you can comment on or make changes to this bug.