Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366621 - WebAdmin login problem with special characters
Summary: WebAdmin login problem with special characters
Keywords:
Status: CLOSED DUPLICATE of bug 1352721
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: AAA
Version: 4.0.1.1
Hardware: All
OS: All
unspecified
medium vote
Target Milestone: ---
: ---
Assignee: Ravi Nori
QA Contact: Gonza
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-12 13:09 UTC by Bojan Popovic
Modified: 2016-08-15 07:58 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-15 07:58:26 UTC
oVirt Team: Infra
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

Description Bojan Popovic 2016-08-12 13:09:41 UTC
Description of problem:
The URLDEcoder crashes when parsing password that contains percent as a special character (%). The error displayed is one of the two below depending on the position of % in password string:
server_error: URLDecoder: Incomplete trailing escape (%) pattern
server_error: URLDecoder: Illegal hex characters in escape (%) pattern - For input string: "whatever"

Percent character (%) can be exchanged with (%25) and the login will be successful, however it is not really convenient.

Version-Release number of selected component (if applicable):
The behavior is the same in oVirt 4.0, 4.0.1 and 4.0.2.6

How reproducible:
Every time

Steps to Reproduce:
1. Change user password so it contains % character
2. Login in the web interface.

Actual results:
Web page displays server_error

Expected results:
Successful login

Additional info:

Comment 1 Ravi Nori 2016-08-15 02:42:58 UTC
This has been reported and fixed by BZ 1352721 and should be part of 4.0.2.6

I just verified on 4.0.2.6 and special characters including % works for passwords. Please test on 4.0.2.6 again

Comment 2 Bojan Popovic 2016-08-15 07:46:54 UTC
(In reply to Ravi Nori from comment #1)
> This has been reported and fixed by BZ 1352721 and should be part of 4.0.2.6
> 
> I just verified on 4.0.2.6 and special characters including % works for
> passwords. Please test on 4.0.2.6 again

You were right I haven't tried 4.0.2.6 version of the oVirt-engine. I am running CentOS 7 and latest available version of oVirt-engine (4.0.1.1), however there are ovirt-engine-setup and ovirt-engine-lib installed with version (4.0.2.6), that made me make a mistake. Sorry about that.

It is working in 4.0.2.6, however ovirt-engine will not update to 4.0.2.6 on CentOS yet using YUM for some reason. It can be done manually downloading required new packages though.

Thanks.

Comment 3 Martin Perina 2016-08-15 07:58:26 UTC
Closing as duplicate of BZ1352721, which is fixed in 4.0.2 release. If the issue still persist after upgrade to 4.0.2, feel free to reopen.

*** This bug has been marked as a duplicate of bug 1352721 ***


Note You need to log in before you can comment on or make changes to this bug.