Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366593 - Unable to add RHEV 3.6 compatible host to RHV 4.0
Summary: Unable to add RHEV 3.6 compatible host to RHV 4.0
Keywords:
Status: CLOSED DUPLICATE of bug 1364787
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Host-Deploy
Version: 4.0.2.4
Hardware: x86_64
OS: Linux
unspecified
urgent vote
Target Milestone: ---
: ---
Assignee: Sandro Bonazzola
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-12 12:20 UTC by SATHEESARAN
Modified: 2016-08-12 13:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-12 13:20:53 UTC
oVirt Team: Node
sasundar: planning_ack?
sasundar: devel_ack?
sasundar: testing_ack?


Attachments (Terms of Use)
gzipped engine.log (deleted)
2016-08-12 12:47 UTC, SATHEESARAN
no flags Details

Description SATHEESARAN 2016-08-12 12:20:30 UTC
Description of problem:
-----------------------
I tried adding RHEV 3.6 compatible host to 3.6 cluster in RHV 4.0.2-4 and hosts are stuck in activating state

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHEV 4.0.2.4-0.1.el7ev

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Create a 3.6 DC in RHV 4.0.2-4
2. Create a 3.6 virt-cluster or gluster-cluster
3. Add a physical host which is compatible with RHEV 3.6 to the newly created 3.6 compatible in cluster in RHV 4.0

Actual results:
----------------
Hosts are stuck in activating state

Expected results:
-----------------
Hosts should get activated

Comment 1 SATHEESARAN 2016-08-12 12:21:17 UTC
Additional info:
----------------

Following errors are seen in engine.log

<snip>
2016-08-12 18:24:12,073 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.GetCapabilitiesVDSCommand] (DefaultQuartzScheduler1) [6d663637] Failed in 'GetCapabilitiesVDS' method, for vds: 'Host-New'; host: 'rhs-client15.lab.eng.blr.redhat.com': null
2016-08-12 18:24:12,073 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.GetCapabilitiesVDSCommand] (DefaultQuartzScheduler1) [6d663637] Command 'GetCapabilitiesVDSCommand(HostName = Host-New, VdsIdAndVdsVDSCommandParametersBase:{runAsync='true', hostId='01043fe3-6db6-4660-84df-67105beb267d', vds='Host[Host-New,01043fe3-6db6-4660-84df-67105beb267d]'})' execution failed: null
2016-08-12 18:24:12,073 ERROR [org.ovirt.engine.core.vdsbroker.monitoring.HostMonitoring] (DefaultQuartzScheduler1) [6d663637] Failure to refresh Vds runtime info: null
2016-08-12 18:24:12,073 ERROR [org.ovirt.engine.core.vdsbroker.monitoring.HostMonitoring] (DefaultQuartzScheduler1) [6d663637] Exception: java.lang.NullPointerException
2016-08-12 18:24:12,073 WARN  [org.ovirt.engine.core.vdsbroker.VdsManager] (DefaultQuartzScheduler1) [6d663637] Failed to refresh VDS , vds = 'Host-New' : '01043fe3-6db6-4660-84df-67105beb267d', error = 'null', continuing.
2016-08-12 18:24:12,073 ERROR [org.ovirt.engine.core.vdsbroker.VdsManager] (DefaultQuartzScheduler1) [6d663637] Exception: java.lang.NullPointerException

</snip>

Comment 2 SATHEESARAN 2016-08-12 12:34:12 UTC
vdsm that I was using on this node

vdsm-hook-vmfex-dev-4.17.33-1.el7ev.noarch
vdsm-infra-4.17.33-1.el7ev.noarch
vdsm-python-4.17.33-1.el7ev.noarch
vdsm-yajsonrpc-4.17.33-1.el7ev.noarch
vdsm-4.17.33-1.el7ev.noarch
vdsm-cli-4.17.33-1.el7ev.noarch
vdsm-xmlrpc-4.17.33-1.el7ev.noarch
vdsm-jsonrpc-4.17.33-1.el7ev.noarch

Comment 3 SATHEESARAN 2016-08-12 12:43:18 UTC
RHEVM UI throws the event as follows :
"Host Host-New installation failed. Failed to configure management network on the host."

Comment 4 SATHEESARAN 2016-08-12 12:47:35 UTC
Created attachment 1190380 [details]
gzipped engine.log

Attaching the engine.log ( gzip compressed )

Comment 5 SATHEESARAN 2016-08-12 13:20:53 UTC

*** This bug has been marked as a duplicate of bug 1364787 ***


Note You need to log in before you can comment on or make changes to this bug.