Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366570 - [userinterface_public_715]It's better to show some message if imagestream has no layers
Summary: [userinterface_public_715]It's better to show some message if imagestream has...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Management Console
Version: 3.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.x
Assignee: Stef Walter
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1367829
TreeView+ depends on / blocked
 
Reported: 2016-08-12 11:00 UTC by Yadan Pei
Modified: 2016-09-19 13:49 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1367829 (view as bug list)
Environment:
Last Closed: 2016-09-19 13:49:53 UTC


Attachments (Terms of Use)
BlankLayersTab (deleted)
2016-08-12 11:00 UTC, Yadan Pei
no flags Details

Description Yadan Pei 2016-08-12 11:00:24 UTC
Description of problem:
For imagestream has no layers it's better to show message indicating no layers

Version-Release number of selected component (if applicable):
v3.3.0.18

How reproducible:
Always

Steps to Reproduce:
1. Create a project and add ImageStreams 
# oc create -f https://raw.githubusercontent.com/openshift/origin/master/examples/image-streams/image-streams-rhel7.json
2. Select imagestream python:2.7
3. Check imagestream layers
# oc get istag python:2.7 -o yaml
image:
  dockerImageLayers: null
4. Go to Layers tab of python:2.7

Actual results:
4. A blank frame is displayed

Expected results:
4. Should give some message telling no layers

Additional info:

Comment 1 Yadan Pei 2016-08-12 11:00:56 UTC
Created attachment 1190346 [details]
BlankLayersTab

Comment 2 Jessica Forrester 2016-08-12 11:54:12 UTC
Stef the fix for this would have to be in the registry-image-layers directive

Comment 3 Stef Walter 2016-08-15 13:03:04 UTC
Are there really no layers? An image should have at least one layer, correct? If so, the message should reflect that reality.

Comment 4 Yadan Pei 2016-08-16 01:52:50 UTC
Hi Stef, I defined python:2.7 as no layers because image.dockerImageLayers is null for python:2.7, this is different from other imagestreams like ruby-22-centos7:latest in my example. Please correct me if anything wrong


Here is yaml of python:2.7 

$ oc get istag python:2.7 -o yaml
apiVersion: v1
generation: 2
image:
  dockerImageLayers: null
  dockerImageMetadata:
    Architecture: amd64



And here is yaml of generated(create app) imagestream ruby-22-centos7:latest

$ oc get istag ruby-22-centos7:latest -o yaml
apiVersion: v1
generation: 2
image:
  dockerImageLayers:
  - mediaType: application/vnd.docker.container.image.rootfs.diff+x-gtar
    name: sha256:a3ed95caeb02ffe68cdd9fd84406680ae93d633cb16422d00e8a7c22955b46d4
    size: 0
  <.....snip...>

Comment 5 Yadan Pei 2016-08-17 05:52:33 UTC
Hi Stef, could you please help check my comment above?

Comment 6 Stef Walter 2016-08-17 13:21:33 UTC
Thanks for the reproducer. Lets just hide the entire 'layers' box in that case.

Comment 7 Stef Walter 2016-08-17 14:52:54 UTC
Fix: https://github.com/openshift/origin-web-console/pull/400

Comment 8 Michal Minar 2016-08-17 15:02:14 UTC
The importer seems to be at fault here. dockerImageLayers shall not be empty for any valid image having layers. And clearly, referenced image [1] does have layers and can be pulled manually using docker 1.10 just fine.

[1] registry.access.redhat.com/rhscl/python-27-rhel7:latest

I'll investigate. Let me clone the bz to Image component.

Comment 9 Yadan Pei 2016-08-18 06:30:43 UTC
Changed product to ORIGIN then we could verify changes earlier and found potential issues as early as possible

Comment 10 Jessica Forrester 2016-08-19 12:32:35 UTC
moving back to ASSIGNED since no fix has gone in yet.  we are figuring out of this is something we need to handle or not

Comment 11 Jessica Forrester 2016-08-19 21:46:21 UTC
Fix merging to origin in https://github.com/openshift/origin/pull/10549

Comment 12 Yadan Pei 2016-08-22 01:39:11 UTC
Now for imagestreams without layers, It will show "No layer information is available for this image"

This is more clear than blank 'layers' box

Move to VERIFIED since it make sense to me


Note You need to log in before you can comment on or make changes to this bug.