Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366562 - Failed to add RHVH to engine with bond configured
Summary: Failed to add RHVH to engine with bond configured
Keywords:
Status: CLOSED DUPLICATE of bug 1366998
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: General
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent vote
Target Milestone: ---
: ---
Assignee: Edward Haas
QA Contact: Gil Klein
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-12 10:35 UTC by dguo
Modified: 2018-06-04 11:26 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-17 06:39:37 UTC
oVirt Team: Network
ylavi: ovirt-4.0.z?
rule-engine: blocker?
ylavi: planning_ack+
fdeutsch: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
Host deploy log in rhvm (deleted)
2016-08-12 10:35 UTC, dguo
no flags Details
sosreport on rhvh (deleted)
2016-08-12 10:36 UTC, dguo
no flags Details
network-script in rhvh (deleted)
2016-08-12 10:38 UTC, dguo
no flags Details
logs under rhvh:/var/tmp (deleted)
2016-08-12 10:40 UTC, dguo
no flags Details
logs under rhvh:/var/log/ (deleted)
2016-08-12 10:40 UTC, dguo
no flags Details
enginee.log (deleted)
2016-08-15 02:53 UTC, dguo
no flags Details
Host deploy log (deleted)
2016-08-15 02:53 UTC, dguo
no flags Details
sosreport on rhvh (deleted)
2016-08-15 02:54 UTC, dguo
no flags Details
rhvh: /var/log (deleted)
2016-08-15 02:55 UTC, dguo
no flags Details
Before creating bond (deleted)
2016-08-16 07:30 UTC, dguo
no flags Details
Creating bond over two nics (deleted)
2016-08-16 07:31 UTC, dguo
no flags Details
Details of bond (deleted)
2016-08-16 07:32 UTC, dguo
no flags Details
Bond ip lost during adding period (deleted)
2016-08-16 07:33 UTC, dguo
no flags Details

Description dguo 2016-08-12 10:35:50 UTC
Created attachment 1190339 [details]
Host deploy log in rhvm

Description of problem:


Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.0-20160811.0.x86_64
imgbased-0.8.4-1.el7ev.noarch
vdsm-4.18.11-1.el7ev.x86_64
Red Hat Virtualization Manager Version: 4.0.2.4-0.1.el7ev

How reproducible:
100%

Steps to Reproduce:
1. Install RHVH4.0
2. Configure a bond with "active backup mode" from cockpit
3. Adding rhvh from rhvm side using the bond ip configured in step#2

Actual results:
After step3, adding rhvh to rhvm failed for "
Failed to configure management network on host dguo_fc. Host dguo_fc has an invalid interface bond0 for the management network configuration.
"

Expected results:
After step3, the rhvh could be added to rhvm successfully

Additional info:
After the failure, checking the network configuration in cockpit, all interfaces
were disappear

Comment 1 dguo 2016-08-12 10:36:54 UTC
Created attachment 1190340 [details]
sosreport on rhvh

Comment 2 dguo 2016-08-12 10:38:57 UTC
Created attachment 1190341 [details]
network-script in rhvh

Comment 3 dguo 2016-08-12 10:40:27 UTC
Created attachment 1190343 [details]
logs under rhvh:/var/tmp

Comment 4 dguo 2016-08-12 10:40:58 UTC
Created attachment 1190344 [details]
logs under rhvh:/var/log/

Comment 5 cshao 2016-08-12 11:01:31 UTC
Add "testblocker" keyword due to it will blocker our bond testing during register to engine.

Comment 6 Fabian Deutsch 2016-08-12 19:51:44 UTC
Please re-test with a new image which is build on or after 20160812

Comment 8 Red Hat Bugzilla Rules Engine 2016-08-12 19:53:20 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 9 Red Hat Bugzilla Rules Engine 2016-08-12 19:56:30 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 10 dguo 2016-08-15 02:52:06 UTC
Caught the same failure "Failed to configure management network on host dguo_intel. Host dguo_intel has an invalid interface bond0 for the management network configuration." with the new image 20160812.0

Comment 11 dguo 2016-08-15 02:53:19 UTC
Created attachment 1190781 [details]
enginee.log

Comment 12 dguo 2016-08-15 02:53:49 UTC
Created attachment 1190782 [details]
Host deploy log

Comment 13 dguo 2016-08-15 02:54:43 UTC
Created attachment 1190783 [details]
sosreport on rhvh

Comment 14 dguo 2016-08-15 02:55:39 UTC
Created attachment 1190784 [details]
rhvh: /var/log

Comment 15 Edward Haas 2016-08-15 12:39:58 UTC
You have been trying to setup a host with a bond and a single slave.
This is not a supported bond setup, a minimum of 2 slaves are required.

Specifically, the failure has been triggered by Engine.


I would suggest opening a bug on providing a proper error message in the log.

Comment 16 Fabian Deutsch 2016-08-15 18:50:13 UTC
Considering comment 15:

Dropping the blocker, adjusting priority, and moving out.

doug, does this bug actually happen with two slaves as well?

Comment 17 Red Hat Bugzilla Rules Engine 2016-08-15 18:50:20 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 19 dguo 2016-08-16 07:30:01 UTC
(In reply to Edward Haas from comment #15)
> You have been trying to setup a host with a bond and a single slave.
> This is not a supported bond setup, a minimum of 2 slaves are required.
> 
> Specifically, the failure has been triggered by Engine.
> 
> 
> I would suggest opening a bug on providing a proper error message in the log.


Re-tested base on suggestion, which creating bond with two slaves up. But unfortunately, adding to rhevm also got failure since the bond ip was lost during the installing period.

Comment 20 dguo 2016-08-16 07:30:55 UTC
Created attachment 1191118 [details]
Before creating bond

Comment 21 dguo 2016-08-16 07:31:29 UTC
Created attachment 1191119 [details]
Creating bond over two nics

Comment 22 dguo 2016-08-16 07:32:09 UTC
Created attachment 1191120 [details]
Details of bond

Comment 23 dguo 2016-08-16 07:33:03 UTC
Created attachment 1191121 [details]
Bond ip lost during adding period

Comment 24 Dan Kenigsberg 2016-08-16 12:26:10 UTC
Can we somehow configure Cockpit to disallow single-slave bonds? Such bonds are most likely mistaken configuration, and ovirt-engine disallows them.

Comment 25 Stef Walter 2016-08-16 13:06:04 UTC
Hi Dan. Adding Marius. He would be a better one ask about that.

Comment 26 Fabian Deutsch 2016-08-16 14:41:57 UTC
I wonder if thsi should be prevented by NM

Comment 27 Edward Haas 2016-08-16 18:27:06 UTC
Results from the tests conducted by mburman:
- Avoid masking NetworkManager allowed the host deployment to finish.
- Configuring a vlan or bond device through Cockpit created an ifcfg file with an uuid as its name. VDSM does not support such naming, it expects the ifcfg file to be named with the device name.

Comment 28 Fabian Deutsch 2016-08-16 19:22:37 UTC
Great findings. We'll revert the masking.

This bug will be used to track the bug which affects the deployment failure.

The ifcfg issue is covered in bug 1367378.

One question: How did you define the bond/vlan?

Comment 29 Dan Kenigsberg 2016-08-17 06:39:37 UTC
we should not track the same issue (masking of NM) on two urgent bugs.

*** This bug has been marked as a duplicate of bug 1366998 ***


Note You need to log in before you can comment on or make changes to this bug.