Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366497 - Slot must be >=1 in auto-assigned PCI address for pci device attached to pci bridge
Summary: Slot must be >=1 in auto-assigned PCI address for pci device attached to pci ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Laine Stump
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-12 06:51 UTC by yangyang
Modified: 2016-08-12 16:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-12 16:39:29 UTC


Attachments (Terms of Use)

Description yangyang 2016-08-12 06:51:40 UTC
Description of problem:
PCI bridge has minimal slot '1'. PCI device attached to pci bridge
is auto-assigned invalid PCI address 0000:01:00.0. But slot must be >= 1


Version-Release number of selected component (if applicable):
libvirt-2.0.0-5.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. define a guest with 1 disk which is attached to pci bridge
<disk type='file' device='disk'>
      <driver name='qemu' type='qcow2'/>
      <source file='/mnt/nfs2/RHEL-7.3-latest.qcow2'/>
      <target dev='vda' bus='virtio'/>
      <address type='pci' bus='0x1'/>
    </disk>

<controller type='pci' index='0' model='pci-root'/>
 <controller type='pci' index='1' model='pci-bridge'>
      <address type='pci' bus='0x0'/>
</controller>

# virsh define vm1-pxb.xml
error: Failed to define domain from vm1-pxb.xml
error: XML error: Invalid PCI address 0000:01:00.0. slot must be >= 1

2.
3.

Actual results:
PCI device attached to pci bridge is auto-assigned PCI address 0000:01:00.0,
but minimal slot of pci bridge is 1


Expected results:
In this case, slot must be >=1 in auto-assigned pci address


Additional info:

Comment 2 Laine Stump 2016-08-12 16:39:29 UTC
There is no auto-assignment happening here, because you've specified a bus. Once you've specified anything beyond just <address type='pci'> (which itself only exists to allow disambiguation between pci and mmio on machinetypes that support both, e.g. aarch64), you have chosen the PCI address yourself. the domain, bus, slot, and function attributes are all optional, and default to 0 if not specified, so if you say:

   <address type='pci' bus='1'/>

that means

   <address type='pci' domain='0x0000' bus='0x01' slot='0x00' function='0x0'/>

If you want to force the device to be on bus 1, then you need to specify everything in the address that isn't 0.


Note You need to log in before you can comment on or make changes to this bug.