Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366492 - unable to install packages
Summary: unable to install packages
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-repos
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-12 06:38 UTC by lnie
Modified: 2016-08-15 11:48 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-15 11:48:30 UTC


Attachments (Terms of Use)
dmesg (deleted)
2016-08-12 06:38 UTC, lnie
no flags Details

Description lnie 2016-08-12 06:38:26 UTC
Created attachment 1190274 [details]
dmesg

Description of problem:
[lnie@localhost ~]$ sudo dnf install tor
Last metadata expiration check: 2:36:43 ago on Thu Aug 11 23:59:23 2016.
Dependencies resolved.
=====================================================================================
 Package            Arch             Version                  Repository        Size
=====================================================================================
Installing:
 tor                x86_64           0.2.7.6-6.fc24           fedora           2.1 M
 torsocks           x86_64           2.1.0-3.fc24             fedora            65 k

Transaction Summary
=====================================================================================
Install  2 Packages

Total size: 2.1 M
Installed size: 9.1 M
Is this ok [y/N]: y
Downloading Packages:
[SKIPPED] tor-0.2.7.6-6.fc24.x86_64.rpm: Already downloaded                         
[SKIPPED] torsocks-2.1.0-3.fc24.x86_64.rpm: Already downloaded                      
warning: /var/cache/dnf/fedora-310f9d37d74ceec1/packages/tor-0.2.7.6-6.fc24.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 81b46521: NOKEY
Curl error (37): Couldn't read a file:// file for file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-25-x86_64 [Couldn't open file /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-25-x86_64]
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
[lnie@localhost ~]$ sudo dnf install xchat
Last metadata expiration check: 2:36:53 ago on Thu Aug 11 23:59:23 2016.
Dependencies resolved.
=====================================================================================
 Package           Arch         Version                  Repository             Size
=====================================================================================
Installing:
 libntlm           x86_64       1.4-5.fc24               fedora                 55 k
 libsexy           x86_64       0.1.11-26.fc24           fedora                 49 k
 python-libs       x86_64       2.7.12-3.fc25            updates-testing       5.8 M
 xchat             x86_64       1:2.8.8-32.fc25          fedora                971 k

Transaction Summary
=====================================================================================
Install  4 Packages

Total size: 6.9 M
Installed size: 28 M
Is this ok [y/N]: y
Downloading Packages:
[SKIPPED] xchat-2.8.8-32.fc25.x86_64.rpm: Already downloaded                        
[SKIPPED] libntlm-1.4-5.fc24.x86_64.rpm: Already downloaded                         
[SKIPPED] libsexy-0.1.11-26.fc24.x86_64.rpm: Already downloaded                     
[SKIPPED] python-libs-2.7.12-3.fc25.x86_64.rpm: Already downloaded                  
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Package xchat-2.8.8-32.fc25.x86_64.rpm is not signed



Version-Release number of selected component (if applicable):
 dnf-1.1.9-3.fc25.noarch

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
 both workstation and server are affected,haven't tested others.

Comment 1 Honza Silhan 2016-08-15 11:39:58 UTC

*** This bug has been marked as a duplicate of bug 1284981 ***

Comment 2 Honza Silhan 2016-08-15 11:42:52 UTC
Sorry, wrong BZ.

Comment 3 Igor Gnatenko 2016-08-15 11:48:30 UTC
Please update fedora-repos first. Then you will get proper GPG key.

Unfortunately DNF can't do much about it.


Note You need to log in before you can comment on or make changes to this bug.