Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366487 - Assigning a host to another organisation using "Fail on Mismatch" always fails
Summary: Assigning a host to another organisation using "Fail on Mismatch" always fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Documentation
Version: 6.2.0
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: 6.2
Assignee: Charles Wood
QA Contact: Lucie Jirakova
URL:
Whiteboard:
: 1243656 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-12 06:26 UTC by Marek Hulan
Modified: 2018-12-06 20:49 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1356246
Environment:
Last Closed: 2017-02-07 16:42:13 UTC


Attachments (Terms of Use)

Description Marek Hulan 2016-08-12 06:26:34 UTC
We need to document how assigning of organization and location to a host works. Please find instructions to reproduce below, the last comment also explain how it works.

+++ This bug was initially created as a clone of Bug #1356246 +++

Description of problem:

Assigning a host to another organisation using "Fail on Mismatch" always fails with below error:
---
Cannot update Organization to test because of mismatch in settings
---

Version-Release number of selected component (if applicable):
6.1.9

How reproducible: Always



Steps to Reproduce:
1 Ensure that you have 2 organizations (we'll call them A and B), and a host assigned to organization A with host group A
2. Go to Hosts / All Hosts, tick the host and then go to Select Action / Assign Organization
3. Attempt to move the host to the new organization with "Fail on Mismatch" and notice it always fails with below error:
----
Cannot update Organization to test because of mismatch in settings
----



Actual results: Fails with below error:
----
Cannot update Organization to test because of mismatch in settings
----


Expected results: If there is no mismatch, It should migrate to B organization without any error.

--- Additional comment from Marek Hulan on 2016-08-11 03:05:55 EDT ---

This happens if there some other resource on a host that does not belong to the organization that user tries to associate. It could be domain, subnet etc. There are two modes for such scenario "Fail on Mismatch" (selected optimistic import = no in code) and "Fix Organization on Mismatch". The first one simply fails if it finds such resource causing the error you reported. Second one updates the resource by adding that organization to it, e.g. adding org A to host's subnet.

I'd say that the behavior you describe is expected, we should just better explain it in the UI (e.g. what resources blocked the association) and what both modes mean. Also we should cover it in documentation.

Comment 1 Daniel Lobato Garcia 2016-12-21 08:54:38 UTC
Any updates on this?

Comment 2 Andrew Dahms 2017-01-11 05:44:43 UTC
Hi Daniel,

Thank you for the needinfo request, and my apologies for the delay in providing a response.

We have yet to assign and start work on this bug, but have recently been focusing on bugs to which customer cases are attached, and this is one of the bugs we are looking to schedule.

I will provide updates as we go along, and will aim for us to start work on this bug shortly.

Kind regards,

Andrew

Comment 3 Andrew Dahms 2017-01-23 05:36:22 UTC
Assigning to Charles for review.

Charles - we need a lot more details about hosts in the Host Configuration Guide, but to address the needs in this bug, it looks like we'll need two new procedures in that guide -

* Assigning a Host to an Organization
* Assigning a Host to a Location

The procedures should go under "Chapter 9. Configuring Hosts", and should outline the major steps, along with the requirements outlined in the last comment of the description above.

Comment 4 Andrew Dahms 2017-02-01 06:22:57 UTC
*** Bug 1243656 has been marked as a duplicate of this bug. ***

Comment 11 Andrew Dahms 2017-02-06 02:32:20 UTC
Hi Charles,

Thank you for working on this bug!

The new procedures look good, but I suspect we may need a little guidance on the error the customer encountered in the initial comment, and the circumstances that cause it.

Would it be possible to add even a note box that provides some more context?

Kind regards,

Andrew


Note You need to log in before you can comment on or make changes to this bug.