Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366485 - virt-install a lxc container failed when setenforce 1
Summary: virt-install a lxc container failed when setenforce 1
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.3
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: rc
: ---
Assignee: Pavel Hrdina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-12 06:21 UTC by yisun
Modified: 2016-09-08 08:57 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-08 08:57:44 UTC


Attachments (Terms of Use)

Description yisun 2016-08-12 06:21:40 UTC
description:
virt-install a lxc container failed when setenforce 1

Versions:
virt-install-1.4.0-1.el7.noarch
libvirt-2.0.0-5.el7.x86_64
kernel-3.10.0-483.el7.x86_64
selinux-policy-3.13.1-92.el7.noarch
libselinux-2.5-4.el7.x86_64

How reproducible:
100%

Steps:
1. virt-install a lxc container failed when setenforce 1
# setenforce 1
# virt-install --connect lxc:/// --name avocado-vt-vm1 --ram 500 --noautoconsole
WARNING  No operating system detected, VM performance may suffer. Specify an OS with --os-variant for optimal results.

Starting install...
ERROR    internal error: guest failed to start: Failure in libvirt_lxc startup: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Domain installation does not appear to have been successful.
If it was, you can restart your domain by running:
  virsh --connect lxc:/// start avocado-vt-vm1
otherwise, please restart your installation.

2. virt-install a lxc container succeeded when setenforce 0
# setenforce 0
# virt-install --connect lxc:/// --name avocado-vt-vm1 --ram 500 --noautoconsole
WARNING  No operating system detected, VM performance may suffer. Specify an OS with --os-variant for optimal results.

Starting install...
Creating domain...                                                                                                             |    0 B  00:00:00    
Domain creation completed.


Expected result:
lxc container succesfully installed.

Comment 1 yisun 2016-08-26 02:17:32 UTC
Tried with libvirt-1.2.17-13.el7.x86_64, not reproducible, so should be a regression in rhel7.3

Comment 3 Pavel Hrdina 2016-09-07 11:57:33 UTC
Hi, please provide libvirtd log.  I was not able to reproduce this bug.

Comment 4 yisun 2016-09-08 08:50:06 UTC
this bug was reproduced with:
selinux-policy-3.13.1-94.el7.noarch

And it's not reproduced with latest selinux-policy:
selinux-policy-3.13.1-97.el7.noarch

So pls close it.


Note You need to log in before you can comment on or make changes to this bug.