Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366477 - net ads testjoin -k --no-dns-updates ends with: Join to domain is not valid: NT code 0xfffffff6
Summary: net ads testjoin -k --no-dns-updates ends with: Join to domain is not valid: ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: samba
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Andreas Schneider
QA Contact: Robin Hack
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-12 05:57 UTC by Robin Hack
Modified: 2016-11-04 07:02 UTC (History)
3 users (show)

Fixed In Version: samba-4.4.4-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 07:02:05 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2468 normal SHIPPED_LIVE samba bug fix and enhancement update 2016-11-03 14:06:51 UTC
Samba Project 12007 None None None 2019-03-19 10:40:59 UTC

Description Robin Hack 2016-08-12 05:57:10 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. join samba to 2003 AD and gain kerberos ticket
2. try to run net commands:
net ads testjoin -k --no-dns-updates
net ads leave -k --no-dns-updates


Actual results:
17:07 <rhack> Join to domain is not valid: NT code 0xfffffff6
17:07 <rhack> :: [   FAIL   ] :: Command 'net ads testjoin -k --no-dns-updates' (Expected 0, got 255)
17:07 <rhack> :: [  BEGIN   ] :: Running 'net ads leave -k --no-dns-updates'
17:07 <rhack> Failed to leave domain: Unable to fetch domain sid: are we joined?
17:07 <rhack> :: [   FAIL   ] :: Command 'net ads leave -k --no-dns-updates' (Expected 0, got 255)


Expected results:
Should work.

Additional info:

Comment 7 errata-xmlrpc 2016-11-04 07:02:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2468.html


Note You need to log in before you can comment on or make changes to this bug.