Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366442 - initial watchdog time is always 50 minutes rather than based on TestTime of first task in recipe
Summary: initial watchdog time is always 50 minutes rather than based on TestTime of f...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: general
Version: 23
Hardware: Unspecified
OS: Unspecified
high
unspecified vote
Target Milestone: 23.2
Assignee: Dan Callaghan
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-12 01:47 UTC by Dan Callaghan
Modified: 2016-09-02 07:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-02 07:01:35 UTC


Attachments (Terms of Use)

Description Dan Callaghan 2016-08-12 01:47:28 UTC
Description of problem:
Since Beaker 23.0 the watchdog time after the reboot command at the start of the installation is always set to a hardcoded value of 50. In previous releases it was actually the TestTime for the first task in the recipe plus 20 minutes.

Version-Release number of selected component (if applicable):
23.0

How reproducible:
somewhat

Steps to Reproduce:
1. Submit a job where the first task in the recipe is not /distribution/install, but some other task which has a very long TestTime
2. Check the watchdog timer immediately after the system is rebooted at the start of the installation

Actual results:
Watchdog timer always starts at 50 minutes.

Expected results:
Prior to Beaker 23.0, watchdog timer would be TestTime of the first task plus 20 minutes.

Additional info:
Longer term the initial watchdog *should* be some smaller value not based on the first task time, because it really reflects how long it takes the machine to netboot and nothing to do with the tasks. For that, there is bug 1138486. But the change has to be done deliberately in a way that won't break existing recipes.

Comment 2 Dan Callaghan 2016-08-12 02:00:31 UTC
As a workaround you could invoke bkr watchdog-extend to extend the watchdog back to the desired value, once the recipe has reached Installing status.

For identifying the recipe bkr watchdog-extend will accept R:123, T:123, or fqdn. The only tricky part is that it requires proper authentication (like all client commands) so it can't just be invoked with no authentication inside a kickstart.

Comment 3 Dan Callaghan 2016-08-12 04:24:17 UTC
http://gerrit.beaker-project.org/5133

Comment 7 Dan Callaghan 2016-09-02 07:01:35 UTC
Beaker 23.2 has been released.


Note You need to log in before you can comment on or make changes to this bug.