Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366414 - sphinx searchd fails to start - FATAL: failed to create pid file...No such file or directory
Summary: sphinx searchd fails to start - FATAL: failed to create pid file...No such fi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sphinx
Version: 24
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Gerald Cox
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-11 23:18 UTC by Gerald Cox
Modified: 2016-08-27 10:18 UTC (History)
2 users (show)

Fixed In Version: sphinx-2.2.11-2.fc24 sphinx-2.2.11-2.fc23 sphinx-2.2.11-2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-27 10:18:26 UTC


Attachments (Terms of Use)

Description Gerald Cox 2016-08-11 23:18:11 UTC
Description of problem:
Upon reboot searchd may fail with:
FATAL: failed to create pid file '/var/run/sphinx/searchd.pid': No such file or directory


Version-Release number of selected component (if applicable):
sphinx-2.2.11-1.fc26.x86_64


How reproducible:
Upon system reboot

Additional info:

Problem was caused by incorrect tmpfiles.d configuration "sphinx.conf".  
Temporary workaround until sphinx-2.2.11-2 is available will be to either
backout to previous version "dnf downgrade sphinx" or simply edit:

/usr/lib/tmpfiles.d/sphinx.conf

and replace contents of file with the following line:
d /run/sphinx 755 sphinx root -

Comment 1 Fedora Update System 2016-08-12 00:30:08 UTC
sphinx-2.2.11-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f3dffc9030

Comment 2 Fedora Update System 2016-08-12 00:30:37 UTC
sphinx-2.2.11-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b0c6345836

Comment 3 Fedora Update System 2016-08-12 20:52:34 UTC
sphinx-2.2.11-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b0c6345836

Comment 4 Fedora Update System 2016-08-12 20:52:34 UTC
sphinx-2.2.11-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f3dffc9030

Comment 5 Fedora Update System 2016-08-20 20:18:27 UTC
sphinx-2.2.11-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7621b0fb18

Comment 6 Fedora Update System 2016-08-20 21:52:13 UTC
sphinx-2.2.11-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2016-08-21 03:18:14 UTC
sphinx-2.2.11-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2016-08-21 19:52:22 UTC
sphinx-2.2.11-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7621b0fb18

Comment 9 Fedora Update System 2016-08-27 10:18:24 UTC
sphinx-2.2.11-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.