Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366402 - [extras-rhel-7.3.0] docker should not depend on oci-register-machine
Summary: [extras-rhel-7.3.0] docker should not depend on oci-register-machine
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: oci-register-machine
Version: 7.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Lokesh Mandvekar
QA Contact: Martin Jenner
URL:
Whiteboard:
: 1359809 1366337 (view as bug list)
Depends On: 1366337
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-11 21:29 UTC by Qian Cai
Modified: 2016-08-26 19:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1366337
Environment:
Last Closed: 2016-08-26 19:19:10 UTC


Attachments (Terms of Use)

Comment 4 Lokesh Mandvekar 2016-08-17 17:43:32 UTC
Moving this to oci-register-machine as enabling/disabling it would be handled via a sysconfig file as per https://github.com/projectatomic/oci-register-machine/pull/22

Comment 5 Qian Cai 2016-08-17 17:50:01 UTC
*** Bug 1366337 has been marked as a duplicate of this bug. ***

Comment 6 Qian Cai 2016-08-17 17:51:31 UTC
*** Bug 1359809 has been marked as a duplicate of this bug. ***

Comment 7 Daniel Walsh 2016-08-19 12:16:57 UTC
Lets remove the dependency since oci-register-machine will not work if docker daemon is in a different mountnamespace.

Comment 8 Daniel Walsh 2016-08-26 19:19:10 UTC
Ok we have gone away from this and now allow oci-register-machine to be disabled.


Note You need to log in before you can comment on or make changes to this bug.