Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366390 - AVC denial when start docker-latest
Summary: AVC denial when start docker-latest
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker-latest
Version: 7.2
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Lokesh Mandvekar
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-11 20:28 UTC by Qian Cai
Modified: 2016-08-11 21:17 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-11 21:17:57 UTC


Attachments (Terms of Use)

Description Qian Cai 2016-08-11 20:28:53 UTC
Description of problem:

# systemctl start docker-latest

# ausearch -m AVC
type=SYSCALL msg=audit(1470947083.829:1878): arch=c000003e syscall=2 success=no exit=-13 a0=4129fb a1=40 a2=180 a3=7fff35434120 items=0 ppid=9062 pid=9162 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="iptables" exe="/usr/sbin/xtables-multi" subj=system_u:system_r:iptables_t:s0 key=(null)
type=AVC msg=audit(1470947083.829:1878): avc:  denied  { read } for  pid=9162 comm="iptables" name="xtables.lock" dev="tmpfs" ino=23109 scontext=system_u:system_r:iptables_t:s0 tcontext=system_u:object_r:var_run_t:s0 tclass=file

Version-Release number of selected component (if applicable):
# rpm -qa | grep docker
docker-latest-1.12.0-4.el7.x86_64
docker-selinux-1.10.3-46.el7.10.x86_64
docker-rhel-push-plugin-1.10.3-46.el7.10.x86_64
docker-common-1.10.3-46.el7.10.x86_64

How reproducible:
always

Comment 1 Qian Cai 2016-08-11 21:17:57 UTC
Probably something messed up on this system. I could not reproduce it on a fresh-installed system.


Note You need to log in before you can comment on or make changes to this bug.