Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366377 - glibc dependency error when installing from ISO on RHEL7.2+
Summary: glibc dependency error when installing from ISO on RHEL7.2+
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.2.0
Hardware: x86_64
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-11 19:43 UTC by Fred van Zwieten
Modified: 2018-08-02 20:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-02 20:59:43 UTC


Attachments (Terms of Use)

Description Fred van Zwieten 2016-08-11 19:43:01 UTC
Description of problem:
When doing the installation from the sat6.2 ISO on a RHEL7.2+ machine, the installation fails due to RPM dependency issues.

Version-Release number of selected component (if applicable):
7.2.0

How reproducible:
Install RHEL7.2
Install Satellite 6.2 from ISO

Steps to Reproduce:
1.
2.
3.

Actual results:
./install_packages
This script will install the satellite packages on the current machine.
   - Ensuring we are in an expected directory.
   - Copying installation files.
   - Creating a Repository File
   - Creating RHSCL Repository File
   - Checking to see if Katello is already installed.
   - Importing the gpg key.
This system is not registered with RHN Classic or Red Hat Satellite.
You can use rhn_register to register.
Red Hat Satellite or RHN Classic support will be disabled.
Error: Package: glibc-2.17-105.el7.i686 (InstallMedia)
           Requires: glibc-common = 2.17-105.el7
           Installed: glibc-common-2.17-106.el7_2.6.x86_64 (@rhel-x86_64-server-7)
               glibc-common = 2.17-106.el7_2.6
           Available: glibc-common-2.17-105.el7.x86_64 (InstallMedia)
               glibc-common = 2.17-105.el7
Error: Package: gnutls-utils-3.3.8-12.el7_1.1.x86_64 (InstallMedia)
           Requires: gnutls(x86-64) = 3.3.8-12.el7_1.1
           Installed: gnutls-3.3.8-14.el7_2.x86_64 (@rhel-x86_64-server-7)
               gnutls(x86-64) = 3.3.8-14.el7_2
           Available: gnutls-3.3.8-12.el7_1.1.x86_64 (InstallMedia)
               gnutls(x86-64) = 3.3.8-12.el7_1.1
Error: Package: gnutls-dane-3.3.8-12.el7_1.1.x86_64 (InstallMedia)
           Requires: gnutls(x86-64) = 3.3.8-12.el7_1.1
           Installed: gnutls-3.3.8-14.el7_2.x86_64 (@rhel-x86_64-server-7)
               gnutls(x86-64) = 3.3.8-14.el7_2
           Available: gnutls-3.3.8-12.el7_1.1.x86_64 (InstallMedia)
               gnutls(x86-64) = 3.3.8-12.el7_1.1
Error while executing command: 'yum install -y satellite'

Expected results:
Installation is succesfull

Additional info:

Comment 3 Bryan Kearney 2017-08-11 13:09:54 UTC
Downloding to high since there is a workaround by downloading the missing pacakges from the portal.

Comment 5 Bryan Kearney 2018-08-02 20:59:43 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.