Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366327 - VDC subscription does not provide/show any product content
Summary: VDC subscription does not provide/show any product content
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management
Version: 6.2.0
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: 6.2
Assignee: Justin Sherrill
QA Contact: jcallaha
URL:
Whiteboard:
: 1373724 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-11 15:56 UTC by rakesh kumar
Modified: 2018-12-06 20:45 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-14 21:01:51 UTC


Attachments (Terms of Use)
verification screenshot (deleted)
2016-09-07 15:02 UTC, jcallaha
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2594971 None None None 2016-10-04 22:18:25 UTC
Red Hat Product Errata RHBA-2016:1885 normal SHIPPED_LIVE Satellite 6.2.2 bug fix update 2016-09-15 00:57:56 UTC

Comment 2 Justin Sherrill 2016-08-19 18:16:16 UTC
I believe this was fixed as part of https://bugzilla.redhat.com/show_bug.cgi?id=134306

The same workaround should fix this issue:

Apply this patch:

https://patch-diff.githubusercontent.com/raw/Katello/katello/pull/6257.patch


Then run the following:


foreman-rake console

User.current = User.first
Katello::Subscription.import_all

Comment 3 Justin Sherrill 2016-08-22 16:03:39 UTC
sorry, the BZ link in the previous  comment should be:  https://bugzilla.redhat.com/show_bug.cgi?id=1343067

Comment 4 Justin Sherrill 2016-08-22 16:04:33 UTC
Moving to POST since https://bugzilla.redhat.com/show_bug.cgi?id=1343067 is now in POST

Comment 5 jcallaha 2016-09-07 15:02:25 UTC
Verified in Satellite 6.2.2. RHEL for Virtual Datacenters subscription now properly shows provided products. See attached screenshot.

Comment 6 jcallaha 2016-09-07 15:02:48 UTC
Created attachment 1198760 [details]
verification screenshot

Comment 13 errata-xmlrpc 2016-09-14 21:01:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1885

Comment 15 Brad Buckingham 2016-09-28 13:08:19 UTC
*** Bug 1373724 has been marked as a duplicate of this bug. ***

Comment 16 Djebran Lezzoum 2017-10-03 16:01:41 UTC
qe_test_coverage PR: https://github.com/SatelliteQE/robottelo/pull/5316


Note You need to log in before you can comment on or make changes to this bug.