Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366313 - AWS EC2 ami-775e4f16 have incorrect /etc/pki/product/69.pem containing RHEL 7.0 Beta
Summary: AWS EC2 ami-775e4f16 have incorrect /etc/pki/product/69.pem containing RHEL 7...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ec2-images
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Joey Boggs
QA Contact: Vratislav Hutsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-11 15:01 UTC by Jan Hutař
Modified: 2017-04-17 12:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-17 12:50:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2463131 None None None 2017-04-17 04:35:09 UTC

Description Jan Hutař 2016-08-11 15:01:46 UTC
Description of problem:
AWS EC2 ami-775e4f16 have incorrect /etc/pki/product/69.pem containing RHEL 7.0 Beta. When I was registering system launched from ami-775e4f16 to Satellite 6, it was consuming (sorry for a wrong terminology) RHEL 7.0 Beta as well. I assume it is because there is this file on the image:


Version-Release number of selected component (if applicable):
ami-775e4f16


How reproducible:
always


Steps to Reproduce:
# rct cat-cert /etc/pki/product/69.pem

+-------------------------------------------+
        Product Certificate
+-------------------------------------------+

Certificate:
        Path: /etc/pki/product/69.pem
        Version: 1.0
        Serial: 12750047592154746697
        Start Date: 2013-11-20 09:38:30+00:00
        End Date: 2033-11-15 09:38:30+00:00

Subject:
        CN: Red Hat Product ID [9b3a0422-3b61-449e-af43-86c274326db0]

Issuer:
        C: US
        CN: Red Hat Entitlement Product Authority
        O: Red Hat, Inc.
        OU: Red Hat Network
        ST: North Carolina
        emailAddress: ca-support@redhat.com

Product:
        ID: 226
        Name: Red Hat Enterprise Linux 7 Public Beta
        Version: 7.0 Beta
        Arch: x86_64
        Tags: rhel-7-everything
        Brand Type:     Brand Name:

There is also this file though:

# rct cat-cert /etc/pki/product-default/69.pem

+-------------------------------------------+
        Product Certificate
+-------------------------------------------+

Certificate:
        Path: /etc/pki/product-default/69.pem
        Version: 1.0
        Serial: 12750047592154746526
        Start Date: 2015-09-11 11:09:22+00:00
        End Date: 2035-09-06 11:09:22+00:00

Subject:
        CN: Red Hat Product ID [eb89dee7-f787-4724-be7d-7ea332d0d9fa]

Issuer:
        C: US
        CN: Red Hat Entitlement Product Authority
        O: Red Hat, Inc.
        OU: Red Hat Network
        ST: North Carolina
        emailAddress: ca-support@redhat.com

Product:
        ID: 69
        Name: Red Hat Enterprise Linux Server
        Version: 7.2
        Arch: x86_64
        Tags: rhel-7,rhel-7-server
        Brand Type:     Brand Name:


Actual results:
Product certificates does not match state of the system as installed by other means.


Expected results:
Certificates should match state of the system as installed by other means.

Comment 3 Joey Boggs 2017-03-22 21:12:15 UTC
Resolved in 7.3 Images

# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.3 (Maipo)


Note You need to log in before you can comment on or make changes to this bug.