Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366267 - WebUI doesn't time out after 60 minutes in step 2D. Detect Undercloud
Summary: WebUI doesn't time out after 60 minutes in step 2D. Detect Undercloud
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 1.0
Assignee: cchase
QA Contact: Tasos Papaioannou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-11 12:37 UTC by Antonin Pagac
Modified: 2016-09-13 16:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:36:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Description Antonin Pagac 2016-08-11 12:37:00 UTC
Description of problem:
In my OSP deployment, I got to step 2D. Detect Undercloud. I then had to wait for my Undercloud machine to finish installing, which apparently took over 60 minutes. I then tried to detect undercloud using the appropriate button and at first try there was red Unathorized message. I then tried again and nothing happened, no message appeared after several tries. In production.log after each try is this message:

"[app] [I] Completed 401 Unauthorized in 2ms (Views: 0.9ms | ActiveRecord: 0.3ms)"

I then refreshed the page and it redirected me to the login screen. After logging in, it works as expected.

Version-Release number of selected component (if applicable):
QCI-1.0-RHEL-7-20160809.t.1
QCIOOO-8.0-RHEL-7-20160806.t.0

How reproducible:
Happened to me once

Steps to Reproduce:
1. Start OSP deployment, go to step 2D. Detect Undercloud
2. Wait for 60+ minutes
3. Try to detect undercloud using valid IP and username/password

Actual results:
At first try, unauthorized message appears in the UI; after second and next tries, no message appears and nothing is happening in the UI; an unauthorized message appears in production.log

Expected results:
After clicking on Detect Undercloud and possibly displaying the unauthorized message, the user should be redirected to login screen

Additional info:

Comment 1 Antonin Pagac 2016-08-11 14:09:51 UTC
Reproduced.

The red message appearing at first try is:

"Undercloud detection failed: {"jqXHR":{"readyState":4,"responseText":"","status":401,"statusText":"Unauthorized"},"textStatus":"error","errorThrown":"Unauthorized"}"

Comment 3 cchase 2016-08-16 21:09:25 UTC
https://github.com/fusor/fusor/pull/1163

You will now be directed to login screen if the deploy undercloud call returns a 401: unauthorized response status.

Comment 4 Tasos Papaioannou 2016-08-31 14:41:11 UTC
Verified on QCI-1.0-RHEL-7-20160829.t.0.

Comment 6 errata-xmlrpc 2016-09-13 16:36:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.