Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366219 - The command ansible-container is missing
Summary: The command ansible-container is missing
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: ansible
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-11 10:09 UTC by Björn Dieding
Modified: 2017-09-25 22:30 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-25 22:30:46 UTC


Attachments (Terms of Use)

Description Björn Dieding 2016-08-11 10:09:39 UTC
Description of problem:

The ansible set of commands is missing a tool. That tool is ansible-container. 

Version-Release number of selected component (if applicable):
n.a.

How reproducible:
always

Steps to Reproduce:
1. yum install ansible or yum install ansible-container


Actual results:
Package does not exist

Expected results:
Package exists

Additional info:

https://github.com/ansible/ansible-container
https://github.com/ansible/ansible-container/blob/develop/INSTALL.md

Comment 1 Kevin Fenzi 2016-08-11 15:42:31 UTC
ansible-container should be it's own seperate package. :) 

Last I looked it was very early and not ready to be packaged up, but that may well have since changed. I do see that they have had a release now, so thats good. 

We just need someone to package it up. I can try that this weekend if no one beats me to it.

Comment 2 Björn Dieding 2016-08-11 15:44:47 UTC
That would be awesome of course. Take your time.

Comment 3 Kevin Fenzi 2016-08-18 21:44:14 UTC
So, I have a tenative package for this, but... 

1) There's a number of missing packages in epel7 for it, so it would require a good deal of work to get all those in. 

2) Upstream hard codes the versions of dependencies they use (pip freeze). They are open to relaxing them, but they don't want to widen their testing and support a bunch all at once. 

That said, I have a package that works for Fedora:

f26/rawhide: http://koji.fedoraproject.org/koji/taskinfo?taskID=15247774

I'm not sure how much time I have to keep working on this. We might want to wait until it's more mature or find someone who has more time to test all the version issues...

Comment 4 Björn Dieding 2016-08-19 08:13:14 UTC
If there are so many hard dependencies in upstream. Should we file a report about it? 

Also I do not mind waiting till EPEL 8 till there are the proper RPMs.

Comment 5 Kevin Fenzi 2016-08-21 17:22:08 UTC
Well, they hard code the versions because they want to reduce what they have to test and limit things to the ones they know for sure will work.

Comment 6 Bill Nottingham 2016-11-15 16:07:53 UTC
I believe James Antill created a COPR for this: http://copr-fe.cloud.fedoraproject.org/coprs/james/ansible-container/builds/

That may be of use as well.

Comment 7 Pim Rupert 2017-03-09 08:56:24 UTC
Since the last discussion a new version of ansible-container was published. Perhaps that one is more suitable for packaging in EPEL?

Comment 8 Kevin Fenzi 2017-09-25 22:30:46 UTC
I personally don't have the cycles to work on this now, so I would encourage other interested folks in doing so.


Note You need to log in before you can comment on or make changes to this bug.