Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366218 - [infrastructure_public_227] `oc idle -l $label` has none output when there is no matched svc
Summary: [infrastructure_public_227] `oc idle -l $label` has none output when there is...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Solly Ross
QA Contact: DeShuai Ma
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-11 10:09 UTC by DeShuai Ma
Modified: 2016-08-12 14:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-12 14:00:52 UTC


Attachments (Terms of Use)

Description DeShuai Ma 2016-08-11 10:09:25 UTC
Description of problem:
When idle a svc with label, if there is no matched svc, the `oc idle -l $label` has empty response.

Version-Release number of selected component (if applicable):
openshift v3.3.0.18
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git

How reproducible:
Always

Steps to Reproduce:
1. Create two project and every project has svc and rc
$ oc login $server
$ oc new-project dma
$ oc create -f https://raw.githubusercontent.com/mdshuai/testfile-openshift/master/k8s/rc-and-svc-list.yaml

2. Label the svc with "idle=true"
$ oc label svc/hello-svc idle=true

3.Idle service with label
$ oc idle -l idle=falsefalse?updated.

Actual results:
3. The output is empty

Expected results:
3. Print useful info like "there is no mached label".

Additional info:

Comment 1 Solly Ross 2016-08-12 14:00:52 UTC
So, if I do `oc get pods -l foo=bar`, for instance, and nothing matches, I don't get any such response, so the current behavior seems to be in line with other commands.  I think this is not a bug.


Note You need to log in before you can comment on or make changes to this bug.