Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366200 - Old sample-pipeline builds disappered in openshift client after edit or check configure page of sample-pipeline project in jenkins webconsole
Summary: Old sample-pipeline builds disappered in openshift client after edit or check...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Troy Dawson
QA Contact: Wang Haoran
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-11 09:48 UTC by XiuJuan Wang
Modified: 2016-09-27 09:43 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:43:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description XiuJuan Wang 2016-08-11 09:48:06 UTC
Description of problem:
sample-pipeline builds disappered in openshift client after edit or just check configure page of sample-pipeline project in jenkins webconsole. Builds exist in jenkins webconsole.

Version-Release number of selected component (if applicable):
jenkins-1-rhel7 (91cc89832f5f)

How reproducible:
always

Steps to Reproduce:
1.Create a jenkinspipeline app
oc new-app -f https://raw.githubusercontent.com/openshift/origin/master/examples/jenkins/pipeline/samplepipeline.json
2.After jenkins pod deploy, trigger some sample-pipeline build from openshift cli and jenkins webcosnole
3.Edit pipeline scripts field in sample-pipeline project configure page,then save.
4.Check builds in openshift cli

Actual results:

Old sample-pipeline builds disappered

Expected results:
Builds shouldn't disapper

Additional info:

Comment 1 Ben Parees 2016-08-12 11:54:18 UTC
Jimmi, does the fix you just dropped for build deletion also address this scenario?

Comment 2 Ben Parees 2016-08-12 15:16:56 UTC
Spoke with Jimmi on IRC and confirmed this should also be fixed by:
https://github.com/jenkinsci/openshift-sync-plugin/pull/7

we'll do a release shortly and get this to QE.

Comment 5 Troy Dawson 2016-08-18 16:39:23 UTC
The change is in jenkins-plugin-openshift-sync-0.0.12-1.el7, which is in openshift3/jenkins-1-rhel7-1.651.2-14 or newer.

Comment 7 Dongbo Yan 2016-08-19 08:42:15 UTC
Test with image
brew.../openshift3/jenkins-1-rhel7        1.651.2             24f906abd158        3 days ago          592.4 MB
brew.../openshift3/jenkins-1-rhel7        1.651.2-14          24f906abd158        3 days ago          592.4 MB
brew.../openshift3/jenkins-1-rhel7        latest              24f906abd158        3 days ago          592.4 MB

still can reproduce this issue

Comment 8 Ben Parees 2016-08-19 13:35:01 UTC
@Troy the pulp image is still showing sync plugin v0.11 instead of v0.12.

Comment 9 Troy Dawson 2016-08-19 20:11:27 UTC
Fixed this time for sure, I've even checked the image manually.

Use image: openshift3/jenkins-1-rhel7:1.651.2-16

This is in pulp, as well as registry.qe and registry.ops

Comment 10 Dongbo Yan 2016-08-22 05:43:39 UTC
Test with 
openshift3/jenkins-1-rhel7       1.651.2-16          19bc08e9d803        2 days ago          626.7 MB
openshift3/jenkins-1-rhel7       latest              19bc08e9d803

this bug is fixed, openshift sync plugin is 0.0.12

Comment 12 errata-xmlrpc 2016-09-27 09:43:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.